realtek: merge duplicated DGS-1210 recipes
authorSander Vanheule <sander@svanheule.net>
Sat, 17 Sep 2022 20:06:37 +0000 (22:06 +0200)
committerSander Vanheule <sander@svanheule.net>
Sat, 17 Sep 2022 20:12:35 +0000 (22:12 +0200)
The D-Link DGS-1210 device series currently has supported devices with
both RTL838x and RTL839x SoCs. An image build recipe has been defined in
both subtarget makefiles, but these are mostly identical, save for the
SOC variable.

Move the SOC variable from the DGS-1210 build recipes to the applicable
devices, and put the remaining duplicate code in a shared Makefile.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/image/common.mk [new file with mode: 0644]
target/linux/realtek/image/rtl838x.mk
target/linux/realtek/image/rtl839x.mk

diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
new file mode 100644 (file)
index 0000000..59286b2
--- /dev/null
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+define Build/d-link_dgs-1210
+  IMAGE_SIZE := 13824k
+  DEVICE_VENDOR := D-Link
+  DLINK_KERNEL_PART_SIZE := 1572864
+  KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
+  CAMEO_KERNEL_PART := 2
+  CAMEO_ROOTFS_PART := 3
+  CAMEO_CUSTOMER_SIGNATURE := 2
+  CAMEO_BOARD_VERSION := 32
+  IMAGES += factory_image1.bin
+  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
+        append-rootfs | pad-rootfs | pad-to 16 | check-size | \
+        dlink-version | dlink-headers
+endef
index 36b19b3cbbf75cf8606cebc10f8d77e9f6780585..2fe2013f702d0534dd3c56565f3263cb0839fbc4 100644 (file)
@@ -1,5 +1,6 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
+include ./common.mk
 
 define Device/allnet_all-sg8208m
   SOC := rtl8382
@@ -11,24 +12,8 @@ define Device/allnet_all-sg8208m
 endef
 TARGET_DEVICES += allnet_all-sg8208m
 
-define Device/d-link_dgs-1210
-  SOC := rtl8382
-  IMAGE_SIZE := 13824k
-  DEVICE_VENDOR := D-Link
-  DLINK_KERNEL_PART_SIZE := 1572864
-  KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
-  CAMEO_KERNEL_PART := 2
-  CAMEO_ROOTFS_PART := 3
-  CAMEO_CUSTOMER_SIGNATURE := 2
-  CAMEO_BOARD_VERSION := 32
-  IMAGES += factory_image1.bin
-  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
-       append-rootfs | pad-rootfs | pad-to 16 | check-size | \
-       dlink-version | dlink-headers
-endef
-
 define Device/d-link_dgs-1210-10mp-f
-  $(Device/d-link_dgs-1210)
+  $(Build/d-link_dgs-1210)
   SOC := rtl8380
   DEVICE_MODEL := DGS-1210-10MP
   DEVICE_VARIANT := F
@@ -37,26 +22,30 @@ endef
 TARGET_DEVICES += d-link_dgs-1210-10mp-f
 
 define Device/d-link_dgs-1210-10p
-  $(Device/d-link_dgs-1210)
+  $(Build/d-link_dgs-1210)
+  SOC := rtl8382
   DEVICE_MODEL := DGS-1210-10P
   DEVICE_PACKAGES += lua-rs232
 endef
 TARGET_DEVICES += d-link_dgs-1210-10p
 
 define Device/d-link_dgs-1210-16
-  $(Device/d-link_dgs-1210)
+  $(Build/d-link_dgs-1210)
+  SOC := rtl8382
   DEVICE_MODEL := DGS-1210-16
 endef
 TARGET_DEVICES += d-link_dgs-1210-16
 
 define Device/d-link_dgs-1210-20
-  $(Device/d-link_dgs-1210)
+  $(Build/d-link_dgs-1210)
+  SOC := rtl8382
   DEVICE_MODEL := DGS-1210-20
 endef
 TARGET_DEVICES += d-link_dgs-1210-20
 
 define Device/d-link_dgs-1210-28
-  $(Device/d-link_dgs-1210)
+  $(Build/d-link_dgs-1210)
+  SOC := rtl8382
   DEVICE_MODEL := DGS-1210-28
 endef
 TARGET_DEVICES += d-link_dgs-1210-28
index 1820875ffd00fed0606c5bf342e121194b106245..f4704544a62e02ea59fa605ca61cfdae837b0153 100644 (file)
@@ -1,23 +1,10 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-define Device/d-link_dgs-1210
-  SOC := rtl8393
-  IMAGE_SIZE := 13824k
-  DEVICE_VENDOR := D-Link
-  DLINK_KERNEL_PART_SIZE := 1572864
-  KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
-  CAMEO_KERNEL_PART := 2
-  CAMEO_ROOTFS_PART := 3
-  CAMEO_CUSTOMER_SIGNATURE := 2
-  CAMEO_BOARD_VERSION := 32
-  IMAGES += factory_image1.bin
-  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
-        append-rootfs | pad-rootfs | pad-to 16 | check-size | \
-        dlink-version | dlink-headers
-endef
+include ./common.mk
 
 define Device/d-link_dgs-1210-52
-  $(Device/d-link_dgs-1210)
+  $(Build/d-link_dgs-1210)
+  SOC := rtl8393
   DEVICE_MODEL := DGS-1210-52
 endef
 TARGET_DEVICES += d-link_dgs-1210-52