build: image: drop unused check-kernel-size recipe
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 29 Jul 2020 19:00:11 +0000 (21:00 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 2 Aug 2020 13:54:43 +0000 (15:54 +0200)
The recipe check-kernel-size is not used in the entire tree. Instead,
we already check the size of the kernel image in Device/Build/kernel
in image.mk via check-size function if KERNEL_SIZE is defined.

Therefore, drop the function. Using it would be redundant anyway.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
include/image-commands.mk

index 7a370034c8fb0a4c3173fd6b1f5c92e9addfec99..9281b91990e223cfb1d8fe7d9024bccfbf5538c0 100644 (file)
@@ -275,13 +275,6 @@ define Build/check-size
        }
 endef
 
        }
 endef
 
-define Build/check-kernel-size
-       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $(IMAGE_KERNEL))" ] || { \
-               echo "WARNING: Kernel for $@ is too big > $(1)" >&2; \
-               rm -f $@; \
-       }
-endef
-
 define Build/combined-image
        -sh $(TOPDIR)/scripts/combined-image.sh \
                "$(IMAGE_KERNEL)" \
 define Build/combined-image
        -sh $(TOPDIR)/scripts/combined-image.sh \
                "$(IMAGE_KERNEL)" \