build and install a current quilt version in tools/
authorFelix Fietkau <nbd@openwrt.org>
Wed, 27 Aug 2008 14:13:32 +0000 (14:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 27 Aug 2008 14:13:32 +0000 (14:13 +0000)
SVN-Revision: 12398

tools/Makefile
tools/quilt/Makefile [new file with mode: 0644]

index 7216d5b158900e81cb195b451eece5483689d87d..816cd98bcea14482550d332ff0e017492c596882 100644 (file)
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
new file mode 100644 (file)
index 0000000..49da92b
--- /dev/null
@@ -0,0 +1,30 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=quilt
+PKG_VERSION:=0.47
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
+PKG_MD5SUM:=d33d2442bd34387260b1c1db3e623af0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)"
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)" install
+endef
+
+define Build/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/quilt
+endef
+
+$(eval $(call HostBuild))