remove references to 2.6.39
authorImre Kaloz <kaloz@openwrt.org>
Sat, 27 Oct 2012 13:47:23 +0000 (13:47 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 27 Oct 2012 13:47:23 +0000 (13:47 +0000)
SVN-Revision: 33967

package/kernel/modules/lib.mk
package/kernel/modules/other.mk
package/kernel/modules/video.mk

index 2875fb23798bc209b7efd53443cadbb85e848ce6..0411e93702c7a4604d81de87975d9153b642fa86 100644 (file)
@@ -55,7 +55,6 @@ $(eval $(call KernelPackage,lib-crc7))
 define KernelPackage/lib-crc8
   SUBMENU:=$(LIB_MENU)
   TITLE:=CRC8 support
-  DEPENDS:= @!LINUX_2_6_39
   KCONFIG:=CONFIG_CRC8
   FILES:=$(LINUX_DIR)/lib/crc8.ko
   AUTOLOAD:=$(call AutoLoad,20,crc8)
@@ -154,7 +153,6 @@ $(eval $(call KernelPackage,lib-zlib))
 define KernelPackage/lib-cordic
   SUBMENU:=$(LIB_MENU)
   TITLE:=Cordic function support
-  DEPENDS:= @!LINUX_2_6_39
   KCONFIG:=CONFIG_CORDIC
   FILES:=$(LINUX_DIR)/lib/cordic.ko
   AUTOLOAD:=$(call AutoLoad,20,cordic)
index 352af2894e979fda003ca00de4f2ce26b5a73238..607b065e528bcb40f926beef90d4176aad60e16a 100644 (file)
@@ -613,7 +613,6 @@ $(eval $(call KernelPackage,mtdtests))
 define KernelPackage/nand
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NAND flash support
-  DEPENDS:=@!LINUX_2_6_39
   KCONFIG:=CONFIG_MTD_NAND \
        CONFIG_MTD_NAND_IDS \
        CONFIG_MTD_NAND_ECC
index 94ea2616aa64513f65d49d5e3f51a9f1d731c3d5..6c5de2ea99fe47b87594dbe59a143135f2cc38b2 100644 (file)
@@ -161,7 +161,7 @@ $(eval $(call KernelPackage,video-sn9c102))
 
 define KernelPackage/video-pwc
   TITLE:=Philips USB webcam support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +!LINUX_2_6_39:kmod-video-videobuf2
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
   KCONFIG:= \
        CONFIG_USB_PWC \
        CONFIG_USB_PWC_DEBUG=n