policycoreutils: install to host/bin not hostpkg
authorPaul Spooren <mail@aparcar.org>
Mon, 28 Sep 2020 08:37:53 +0000 (22:37 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 28 Sep 2020 23:06:32 +0000 (00:06 +0100)
By installing policycoreutils to host/bin it is also available within
the ImageBuilder and SDK, allowing to correctly label both filesystems
and packages.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/image.mk
package/utils/policycoreutils/Makefile

index da3d500e81270abd86a04e3282990b49df858873..f72095db56345e1ca803a56cc93cc2416bebc7d4 100644 (file)
@@ -243,7 +243,7 @@ endef
 
 ifeq ($(CONFIG_TARGET_ROOTFS_SECURITY_LABELS),y)
 define Image/mkfs/squashfs
-       echo "$(STAGING_DIR_HOSTPKG)/bin/setfiles -r" \
+       echo "$(STAGING_DIR_HOST)/bin/setfiles -r" \
             "$(call mkfs_target_dir,$(1))" \
             "$(call mkfs_target_dir,$(1))/etc/selinux/targeted/contexts/files/file_contexts " \
             "$(call mkfs_target_dir,$(1))" > $@.fakeroot-script
index 6b7b78ed785545cb67f01474d193c4af43e16015..a237542be60cc8c4f48efc67fc39364c963fb5a5 100644 (file)
@@ -67,7 +67,7 @@ MAKE_FLAGS += \
 
 HOST_MAKE_FLAGS += \
        PAMH=$(CONFIG_BUSYBOX_CONFIG_PAM) \
-       DESTDIR=$(STAGING_DIR_HOSTPKG) \
+       DESTDIR=$(STAGING_DIR_HOST) \
        PREFIX= \
        SBINDIR=/bin