build: fix removal of old .ipk files with CONFIG_PER_FEED_REPO
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 9 Aug 2014 13:04:17 +0000 (13:04 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 9 Aug 2014 13:04:17 +0000 (13:04 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 42090

include/package-ipkg.mk

index be47526467ae7550d9c91a4c4b7e533120fe7a33..5c83b3d58bac37e5b83b4c3a0a212604eba05346 100644 (file)
@@ -136,7 +136,7 @@ ifeq ($(DUMP),)
 
     $(PKG_INFO_DIR)/$(1).provides: $$(IPKG_$(1))
     $$(IPKG_$(1)): $(STAMP_BUILT) $(INCLUDE_DIR)/package-ipkg.mk
-       @rm -rf $(PACKAGE_DIR)/$(1)_* $$(IDIR_$(1))
+       @rm -rf $$(PDIR_$(1))/$(1)_* $$(IDIR_$(1))
        mkdir -p $(PACKAGE_DIR) $$(IDIR_$(1))/CONTROL $(PKG_INFO_DIR)
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| $(XARGS) rm -rf