prereq-build: recognize Python 3.10
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Tue, 28 Sep 2021 13:03:24 +0000 (15:03 +0200)
committerPaul Spooren <mail@aparcar.org>
Sat, 9 Oct 2021 02:34:51 +0000 (16:34 -1000)
Fedora 35 contains Python 3.10 as default version. Make use of it.

Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
[fix commit subject]
Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit e1c03ca18519f9683f6bfce1795e58d99575d895)

include/prereq-build.mk

index 623881c93f1721353f85aef9081cb6aadcae664c..8b6413564db482bc8833288c28c6839b188051f9 100644 (file)
@@ -153,6 +153,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+       python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
@@ -161,6 +162,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
        python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+       python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \