ramips: Adding support for AXIMCom MR-102N 3G/4G Travel Mobile Router
authorJohn Crispin <john@openwrt.org>
Sat, 23 May 2015 15:27:05 +0000 (15:27 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 23 May 2015 15:27:05 +0000 (15:27 +0000)
MR-102N is a RT3050F based wireless router(32M RAM + 8M NOR flash) with 1 USB
and 1 ethernet port.  The original product information can be found at:
http://www.aximcom.com/en/MR-102N

Signed-off-by: Tai-hwa Liang <atliang@gmail.com>

SVN-Revision: 45724

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/MR-102N.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/aximcom.mk [new file with mode: 0644]

index 80623f4a8d182956b0c135b3cec7419717abf5cd..ad0062a56bba30147e15579b33fb618a1e5c3245 100755 (executable)
@@ -145,6 +145,10 @@ case $board in
        mpr-a2)
                set_wifi_led "hame:blue:system"
                ;;
+       mr-102n)
+               set_wifi_led "mr-102n:green:wlan"
+               set_usb_led "mr-102n:green:usb"
+               ;;
        mzk-w300nh2)
                set_wifi_led "mzkw300nh2:amber:wlan"
                ;;
index c8ef69f2c009ad7da37e72fedc14b3ddaf90eace..43a0e54f7388e4728b85c53d399c82234436f6a1 100755 (executable)
@@ -61,7 +61,8 @@ ramips_setup_interfaces()
                ;;
 
        3g-6200nl | \
-       mlw221)
+       mlw221 | \
+       mr-102n)
                ucidef_set_interface_lan "eth0.2"
                ;;
        mlwg2)
index caede7bcc86964969ef58ea82654cd610a64b9d8..6bba7e4394814b3c9c00bc525ded5475b42f97e6 100644 (file)
@@ -104,6 +104,9 @@ get_status_led() {
        mpr-a2)
                status_led="hame:red:power"
                ;;
+       mr-102n)
+               status_led="mr-102n:amber:status"
+               ;;
        nbg-419n)
                status_led="nbg-419n:green:power"
                ;;
index 5769d26c2c1c449c77259cdf369e47cee8c73f62..cd4e39c5f7918d58e0abcb246a73bf81b03b2134 100755 (executable)
@@ -85,6 +85,9 @@ ramips_board_detect() {
        *"Aztech HW550-3G")
                name="hw550-3g"
                ;;
+       *"AXIMCom MR-102N")
+               name="mr-102n"
+               ;;
        *"Buffalo WSR-600DHP")
                name="wsr-600"
                ;;
index 4ecf3314dc15456d2beff42d4ece70f05c17ef2e..0a54d3747cc593245e5a131068efe450d352005b 100755 (executable)
@@ -67,6 +67,7 @@ platform_check_image() {
        mofi3500-3gn | \
        mpr-a1 | \
        mpr-a2 | \
+       mr-102n | \
        mzk-w300nh2 | \
        nbg-419n | \
        nw718 | \
diff --git a/target/linux/ramips/dts/MR-102N.dts b/target/linux/ramips/dts/MR-102N.dts
new file mode 100644 (file)
index 0000000..c2a6e24
--- /dev/null
@@ -0,0 +1,111 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "MR-102N", "ralink,rt3052-soc";
+       model = "AXIMCom MR-102N";
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x790000>;
+               };
+
+               partition@7e0000 {
+                       label = "nvram";
+                       reg = <0x7e0000 0x10000>;
+               };
+
+               partition@7f0000 {
+                       label = "nvram_backup";
+                       reg = <0x7f0000 0x10000>;
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               status = "okay";
+               #ralink,portmap = <0x3e>;
+               ralink,portmap = <0x2f>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               usb {
+                       label = "mr-102n:green:usb";
+                       gpios = <&gpio0 8 1>;
+               };
+               status {
+                       label = "mr-102n:amber:status";
+                       gpios = <&gpio0 9 1>;
+               };
+               wlan {
+                       label = "mr-102n:green:wlan";
+                       gpios = <&gpio0 11 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 13 1>;
+                       linux,code = <0x198>;
+               };
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 18 1>;
+                       linux,code = <0x211>;
+               };
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index 2f4fdf16edc66a27c77d81b7bf77449684a13800..b0b35796a7b8fcfe32b4338a06a112db04546894 100644 (file)
@@ -554,6 +554,8 @@ Image/Build/Profile/MOFI3500-3GN=$(call BuildFirmware/Default8M/$(1),$(1),mofi35
 # Kernel name should be "Linux Kernel Image" to make the OpenWrt image installable from factory Web UI
 Image/Build/Profile/3G150B=$(call BuildFirmware/Default4M/$(1),$(1),3g150b,3G150B,Linux Kernel Image)
 
+Image/Build/Profile/MR102N=$(call BuildFirmware/Default8M/$(1),$(1),mr-102n,MR-102N)
+
 Image/Build/Profile/MPRA1=$(call BuildFirmware/Default4M/$(1),$(1),mpr-a1,MPRA1,Linux Kernel Image)
 Image/Build/Profile/MPRA2=$(call BuildFirmware/Default8M/$(1),$(1),mpr-a2,MPRA2,Linux Kernel Image)
 
@@ -724,6 +726,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/M3,$(1))
        $(call Image/Build/Profile/M4,$(1))
        $(call Image/Build/Profile/MOFI3500-3GN,$(1))
+       $(call Image/Build/Profile/MR102N,$(1))
        $(call Image/Build/Profile/MPRA1,$(1))
        $(call Image/Build/Profile/MPRA2,$(1))
        $(call Image/Build/Profile/MZKW300NH2,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/aximcom.mk b/target/linux/ramips/rt305x/profiles/aximcom.mk
new file mode 100644 (file)
index 0000000..eb305af
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MR102N
+       NAME:=AXIMCom MR-102N
+       PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-ledtrig-usbdev
+endef
+
+define Profile/MR102N/Description
+       Package set for AXIMCom MR-102N
+endef
+
+$(eval $(call Profile,MR102N))