Add the RDC PCI ids for a fancier PCI device table.Return the system name on boot.
authorFlorian Fainelli <florian@openwrt.org>
Mon, 15 Oct 2007 16:13:25 +0000 (16:13 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 15 Oct 2007 16:13:25 +0000 (16:13 +0000)
SVN-Revision: 9327

target/linux/rdc/files/arch/i386/mach-rdc/Makefile
target/linux/rdc/files/arch/i386/mach-rdc/setup.c [new file with mode: 0644]
target/linux/rdc/patches/004-rdc_fixes.patch
target/linux/rdc/patches/006-pci_ids.patch [new file with mode: 0644]

index 5961bc791046cf4454f0727799f1f3b30fd8ae41..07a92038d0f7b0700fc7d5b6139110766a2aacb6 100644 (file)
@@ -1,5 +1,5 @@
 #
 # Makefile for the RDC321x specific parts of the kernel
 #
-obj-$(CONFIG_X86_RDC)        := gpio.o platform.o wdt.o
+obj-$(CONFIG_X86_RDC)        := gpio.o platform.o wdt.o setup.o
 
diff --git a/target/linux/rdc/files/arch/i386/mach-rdc/setup.c b/target/linux/rdc/files/arch/i386/mach-rdc/setup.c
new file mode 100644 (file)
index 0000000..ad206c3
--- /dev/null
@@ -0,0 +1,14 @@
+/*
+ *     Machine specific setup for generic
+ */
+
+#include <linux/init.h>
+#include <linux/interrupt.h>
+#include <asm/arch_hooks.h>
+#include <asm/io.h>
+#include <asm/setup.h>
+
+char * __init machine_specific_memory_setup(void)
+{
+       return "RDC R-321x";
+}
index 524155adf6f522d50035a1544a1a60fbff4d487e..e67678a8e826223f0ac22563ae36807cc724b3e5 100644 (file)
@@ -67,7 +67,7 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
  };
  
  static struct device_fixup fixups_table[] = {
-+{ 0x17F3, 0x6030, r8610_reset },
++{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_R6030, r8610_reset },
  { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
  { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
  };
diff --git a/target/linux/rdc/patches/006-pci_ids.patch b/target/linux/rdc/patches/006-pci_ids.patch
new file mode 100644 (file)
index 0000000..cd4c01d
--- /dev/null
@@ -0,0 +1,18 @@
+diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
+index 55f307f..4a1aa34 100644
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -2076,6 +2076,13 @@
+ #define PCI_DEVICE_ID_HERC_WIN                0x5732
+ #define PCI_DEVICE_ID_HERC_UNI                0x5832
++#define PCI_VENDOR_ID_RDC             0x17f3
++#define PCI_DEVICE_ID_RDC_R6020               0x6020
++#define PCI_DEVICE_ID_RDC_R6030               0x6030
++#define PCI_DEVICE_ID_RDC_R6040               0x6040
++#define PCI_DEVICE_ID_RDC_R6060               0x6060
++#define PCI_DEVICE_ID_RDC_R6061               0x6061
++
+ #define PCI_VENDOR_ID_SITECOM         0x182d
+ #define PCI_DEVICE_ID_SITECOM_DC105V2 0x3069