layerscape: enlarge ext4 rootfs size to 30MB
authorYangbo Lu <yangbo.lu@nxp.com>
Mon, 23 Oct 2017 11:03:00 +0000 (19:03 +0800)
committerJohn Crispin <john@phrozen.org>
Fri, 10 Nov 2017 22:00:49 +0000 (23:00 +0100)
This patch is to enlarge ext4 rootfs size to 30MB.

Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
package/boot/uboot-layerscape-armv8_32b/Makefile
package/boot/uboot-layerscape/patches/0002-armv8-ls1046ardb-add-LEDE-boot-support-in-environmen.patch
package/boot/uboot-layerscape/patches/0003-armv8-ls1012ardb-add-LEDE-boot-support-in-environmen.patch
package/boot/uboot-layerscape/patches/0004-armv8-ls1088ardb-add-LEDE-boot-support-in-environmen.patch
target/linux/layerscape/image/Makefile

index 3b532b3ba48b04b014c48e5e1b597ed0d8916326..1e0eb34171a86a1e0e9231e6b68cee9452a59aa7 100644 (file)
@@ -17,8 +17,8 @@ PKG_RELEASE:=1
 # uboot-layerscape's source code.
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/yangbolu1991/u-boot-lede.git
-PKG_SOURCE_VERSION:=b973f9b8754440d8db4ead6cd59a6ad2f7378806
-PKG_MIRROR_HASH:=4297f79e502f869a042271877a0e5ac3b78f914c5797c53a48da0d7769e08fc7
+PKG_SOURCE_VERSION:=050c7f11e2ad1a005baa8816699a5c4543dab70c
+PKG_MIRROR_HASH:=ebd63c29417616240090930d50bbce46956de8ddc3f2aa1b238da286ff66794a
 
 PKG_MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
 
index 715d7869a1bed54148a31e9712363cad18720304..418f6287fba1254e7b85c45d945896674f794ff7 100644 (file)
@@ -26,7 +26,7 @@ index 4fc2f94..53bd41b 100644
 +              "earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 " \
 +              "mtdparts=1550000.quadspi:1M(rcw),2M(u-boot),1M(u-boot-env)," \
 +              "5M(reserved-1),256k(fman),5888k(reserved-2),1M(dtb)," \
-+              "16M(kernel),22M(ext4rfs),10M(user)\0" \
++              "16M(kernel),30M(ext4rfs),2M(user)\0" \
 +      "lede_run=sf probe 0:0 && " \
 +              "sf read $fdtaddr f00000 100000 && " \
 +              "sf read $loadaddr 1000000 1000000 && " \
index 197735afaff90bd8b858d9f78a694e96214bb704..e8bbe7faa386b4debd61767ea6167b5d9d6188e2 100644 (file)
@@ -25,7 +25,7 @@ index 5fe3218..242cdf0 100644
 +              "earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 " \
 +              "mtdparts=1550000.quadspi:1M(rcw),2M(u-boot),1M(u-boot-env)," \
 +              "5M(reserved-1),256k(fman),5888k(reserved-2),1M(dtb)," \
-+              "16M(kernel),23M(ext4rfs),9M(user)\0" \
++              "16M(kernel),30M(ext4rfs),2M(user)\0" \
 +      "lede_run=pfe stop && sf probe 0:0 && " \
 +              "sf read $fdtaddr f00000 100000 && " \
 +              "sf read $loadaddr 1000000 1000000 && " \
index 72c43ebcd0b6822d1b4f03a1381f7439d30c67f9..eaf0da28337224b48a0c8cf6f77ac9f97c1fafb6 100644 (file)
@@ -25,7 +25,7 @@ index 7bd152d..4cefa40 100644
 +              "earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 " \
 +              "mtdparts=20c0000.quadspi:1M(rcw),2M(u-boot),1M(u-boot-env)," \
 +              "6M(reserved-1),3M(mc),1M(dpl),1M(dpc),1M(dtb)," \
-+              "16M(kernel),17M(ext4rfs),15M(user)\0" \
++              "16M(kernel),30M(ext4rfs),2M(user)\0" \
 +      "lede_run=sf probe 0:0 && " \
 +              "sf read $fdtaddr f00000 100000 && " \
 +              "sf read $loadaddr 1000000 1000000 && " \
index d1449aa10540bef0bb815f6f7c74e184ce5938d2..26c57678f167e556e8ea39484cd3a87d3561b2ef 100644 (file)
@@ -95,7 +95,7 @@ define Device/ls1046ardb
                        append-ls-fman $(1) | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
-                       append-ls-rootfs-ext4 $(1) 22M | check-size 67108865
+                       append-ls-rootfs-ext4 $(1) 30M | check-size 67108865
 endef
 TARGET_DEVICES += ls1046ardb
 
@@ -110,7 +110,7 @@ define Device/ls1012ardb
                        append-ls-ppfe | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
-                       append-ls-rootfs-ext4 $(1) 23M | check-size 67108865
+                       append-ls-rootfs-ext4 $(1) 30M | check-size 67108865
 endef
 TARGET_DEVICES += ls1012ardb
 
@@ -129,7 +129,7 @@ define Device/ls1088ardb
                        append-ls-dpc $(1) | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
-                       append-ls-rootfs-ext4 $(1) 17M | check-size 67108865
+                       append-ls-rootfs-ext4 $(1) 30M | check-size 67108865
 endef
 TARGET_DEVICES += ls1088ardb