Revert "dnsmasq: improve insecure DS warning"
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 3 Aug 2019 19:55:45 +0000 (20:55 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 3 Aug 2019 19:55:45 +0000 (20:55 +0100)
This reverts commit cd91f2327ffb06a41129a35ae7be1e7923a78d74.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/patches/130-dnssec-add-hostname-info-to-insecure-DS-warning.patch [deleted file]

index ad95ccd65d435b65d02bf8b3f2321f900ad666ea..dc20ada292ab8db9aadb406fc30a828c3bd8c8ba 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=dnsmasq
 PKG_UPSTREAM_VERSION:=2.80
 PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=16
+PKG_RELEASE:=14
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/patches/130-dnssec-add-hostname-info-to-insecure-DS-warning.patch b/package/network/services/dnsmasq/patches/130-dnssec-add-hostname-info-to-insecure-DS-warning.patch
deleted file mode 100644 (file)
index e3ef604..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From a1030c159e28bbfa966799e7b9a86081398d6352 Mon Sep 17 00:00:00 2001
-From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
-Date: Sat, 11 May 2019 16:04:56 +0100
-Subject: [PATCH] dnssec: add hostname info to insecure DS warning
-
-Make the existing "insecure DS received" warning more informative by
-reporting the domain name reporting the issue.
-
-This may help identify a problem with a specific domain or server
-configuration.
-
-Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
----
- src/dnssec.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/src/dnssec.c
-+++ b/src/dnssec.c
-@@ -873,7 +873,7 @@ int dnssec_validate_ds(time_t now, struc
-   
-   if (rc == STAT_INSECURE)
-     {
--      my_syslog(LOG_WARNING, _("Insecure DS reply received, do upstream DNS servers support DNSSEC?"));
-+      my_syslog(LOG_WARNING, _("Insecure DS reply received for %s, check domain configuration and upstream DNS server DNSSEC support"), name);
-       rc = STAT_BOGUS;
-     }
-