kernel: bump 4.14 to 4.14.74
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 4 Oct 2018 09:26:55 +0000 (11:26 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 4 Oct 2018 14:15:03 +0000 (16:15 +0200)
Refreshed all patches.

Fixes CVE:

- CVE-2018-7755

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/ipq806x/patches-4.14/0063-2-tsens-support-configurable-interrupts.patch
target/linux/mediatek/patches-4.14/0064-dts.patch
target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
target/linux/ramips/patches-4.14/0031-uvc-add-iPassion-iP2970-support.patch

index 861b4c5a7a8c5106349dc7150954245d72fcaf2f..8f01583aedca1243aa5b4e0d294b946336381fea 100644 (file)
@@ -3,12 +3,12 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .123
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .123
-LINUX_VERSION-4.14 = .73
 LINUX_VERSION-4.9 = .131
 LINUX_VERSION-4.9 = .131
+LINUX_VERSION-4.14 = .74
 
 LINUX_KERNEL_HASH-3.18.123 = c10de32c9b31fb619b016a00d77afc394db5a4542e258e927f06a5ead86f8c64
 
 LINUX_KERNEL_HASH-3.18.123 = c10de32c9b31fb619b016a00d77afc394db5a4542e258e927f06a5ead86f8c64
-LINUX_KERNEL_HASH-4.14.73 = 999e38141ccc447df7bf7ce10b8803c12b32274b76d3d5400bf3fd88eee0e31e
 LINUX_KERNEL_HASH-4.9.131 = 57db3295469d3990af93703a97b07f1e8a14920bf3f5b68ce0330a02e7aa5d60
 LINUX_KERNEL_HASH-4.9.131 = 57db3295469d3990af93703a97b07f1e8a14920bf3f5b68ce0330a02e7aa5d60
+LINUX_KERNEL_HASH-4.14.74 = 70e69189fd7b2f96fa33833735c7bcf3281dc0172c3734e2c5819e9d57015c72
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 46c12e0c182a73629bfec5c59c009f7d44b47c0d..e89786b47aba93d1e3442b3cedd0401d53165d55 100644 (file)
@@ -29,7 +29,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/fs/locks.c
 +++ b/fs/locks.c
 
 --- a/fs/locks.c
 +++ b/fs/locks.c
-@@ -2805,6 +2805,8 @@ static const struct file_operations proc
+@@ -2812,6 +2812,8 @@ static const struct file_operations proc
  
  static int __init proc_locks_init(void)
  {
  
  static int __init proc_locks_init(void)
  {
index 4469896ae28843a885e7e6a6812aeceeca9f131d..944d1e575bda3688b52d6df241e8bdb642ec2dad 100644 (file)
@@ -79,7 +79,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
                return -EINVAL;
  
        return data->ops->get_trend(data->sensor_data, trip, trend);
                return -EINVAL;
  
        return data->ops->get_trend(data->sensor_data, trip, trend);
-@@ -286,7 +290,9 @@ static int of_thermal_set_mode(struct th
+@@ -289,7 +293,9 @@ static int of_thermal_set_mode(struct th
        mutex_unlock(&tz->lock);
  
        data->mode = mode;
        mutex_unlock(&tz->lock);
  
        data->mode = mode;
@@ -90,7 +90,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
  
        return 0;
  }
  
        return 0;
  }
-@@ -296,7 +302,8 @@ static int of_thermal_get_trip_type(stru
+@@ -299,7 +305,8 @@ static int of_thermal_get_trip_type(stru
  {
        struct __thermal_zone *data = tz->devdata;
  
  {
        struct __thermal_zone *data = tz->devdata;
  
@@ -100,7 +100,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
                return -EDOM;
  
        *type = data->trips[trip].type;
                return -EDOM;
  
        *type = data->trips[trip].type;
-@@ -304,12 +311,39 @@ static int of_thermal_get_trip_type(stru
+@@ -307,12 +314,39 @@ static int of_thermal_get_trip_type(stru
        return 0;
  }
  
        return 0;
  }
  
@@ -141,7 +141,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
                return -EDOM;
  
        *temp = data->trips[trip].temperature;
                return -EDOM;
  
        *temp = data->trips[trip].temperature;
-@@ -322,7 +356,8 @@ static int of_thermal_set_trip_temp(stru
+@@ -325,7 +359,8 @@ static int of_thermal_set_trip_temp(stru
  {
        struct __thermal_zone *data = tz->devdata;
  
  {
        struct __thermal_zone *data = tz->devdata;
  
@@ -151,7 +151,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
                return -EDOM;
  
        if (data->ops->set_trip_temp) {
                return -EDOM;
  
        if (data->ops->set_trip_temp) {
-@@ -344,7 +379,8 @@ static int of_thermal_get_trip_hyst(stru
+@@ -347,7 +382,8 @@ static int of_thermal_get_trip_hyst(stru
  {
        struct __thermal_zone *data = tz->devdata;
  
  {
        struct __thermal_zone *data = tz->devdata;
  
@@ -161,7 +161,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
                return -EDOM;
  
        *hyst = data->trips[trip].hysteresis;
                return -EDOM;
  
        *hyst = data->trips[trip].hysteresis;
-@@ -357,7 +393,8 @@ static int of_thermal_set_trip_hyst(stru
+@@ -360,7 +396,8 @@ static int of_thermal_set_trip_hyst(stru
  {
        struct __thermal_zone *data = tz->devdata;
  
  {
        struct __thermal_zone *data = tz->devdata;
  
@@ -171,7 +171,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
                return -EDOM;
  
        /* thermal framework should take care of data->mask & (1 << trip) */
                return -EDOM;
  
        /* thermal framework should take care of data->mask & (1 << trip) */
-@@ -432,6 +469,9 @@ thermal_zone_of_add_sensor(struct device
+@@ -435,6 +472,9 @@ thermal_zone_of_add_sensor(struct device
        if (ops->set_emul_temp)
                tzd->ops->set_emul_temp = of_thermal_set_emul_temp;
  
        if (ops->set_emul_temp)
                tzd->ops->set_emul_temp = of_thermal_set_emul_temp;
  
@@ -181,7 +181,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
        mutex_unlock(&tzd->lock);
  
        return tzd;
        mutex_unlock(&tzd->lock);
  
        return tzd;
-@@ -726,7 +766,10 @@ static const char * const trip_types[] =
+@@ -729,7 +769,10 @@ static const char * const trip_types[] =
        [THERMAL_TRIP_ACTIVE]   = "active",
        [THERMAL_TRIP_PASSIVE]  = "passive",
        [THERMAL_TRIP_HOT]      = "hot",
        [THERMAL_TRIP_ACTIVE]   = "active",
        [THERMAL_TRIP_PASSIVE]  = "passive",
        [THERMAL_TRIP_HOT]      = "hot",
index 08feb8d731e86b9afd959917e21e6b867e8edb46..a2f5000d4d16975d89c626fb67705583e4a6fbd7 100644 (file)
 +
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
 +
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -323,6 +323,7 @@
+@@ -326,6 +326,7 @@
                             "syscon";
                reg = <0 0x10209000 0 0x1000>;
                #clock-cells = <1>;
                             "syscon";
                reg = <0 0x10209000 0 0x1000>;
                #clock-cells = <1>;
index 68dd23bdb964f57f731493d77f1f4aa1c7933ec6..c5eb54ae445ae059d65a21052f7038e31366f2fb 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] arm: dts: Add missing mt7623 pcie nodes
 
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
 
 --- a/arch/arm/boot/dts/mt7623.dtsi
 +++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -671,6 +671,111 @@
+@@ -674,6 +674,111 @@
                #reset-cells = <1>;
        };
  
                #reset-cells = <1>;
        };
  
index 5829b2fdd0c84a89d8faab5f23f8f45ddf221726..85a5c1310c1a388ffe67d032d552419e6b857153 100644 (file)
@@ -64,7 +64,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <media/v4l2-common.h>
  
  
  #include <media/v4l2-common.h>
  
-@@ -1081,9 +1086,149 @@ static void uvc_video_decode_data(struct
+@@ -1093,9 +1098,149 @@ static void uvc_video_decode_data(struct
        }
  }
  
        }
  }
  
@@ -214,7 +214,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        /* Mark the buffer as done if the EOF marker is set. */
        if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
                uvc_trace(UVC_TRACE_FRAME, "Frame complete (EOF found).\n");
        /* Mark the buffer as done if the EOF marker is set. */
        if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
                uvc_trace(UVC_TRACE_FRAME, "Frame complete (EOF found).\n");
-@@ -1498,6 +1643,8 @@ static int uvc_init_video_isoc(struct uv
+@@ -1510,6 +1655,8 @@ static int uvc_init_video_isoc(struct uv
        if (npackets == 0)
                return -ENOMEM;
  
        if (npackets == 0)
                return -ENOMEM;