build: fix libressl build on x32 (amd64ilp32) host
authorThorsten Glaser <tg@mirbsd.org>
Mon, 22 Oct 2018 19:00:57 +0000 (21:00 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 Nov 2018 16:16:52 +0000 (17:16 +0100)
disable use of assembly code since x32 gets misdetected as amd64

Signed-off-by: Thorsten Glaser <tg@mirbsd.org>
tools/libressl/Makefile

index 57cdacd961ed0a31cd54ef12ce7cbb2a619fc3f7..8894a058e4303adcb5908a4835fe3575a1825c74 100644 (file)
@@ -26,4 +26,8 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += --disable-shared
 HOST_CFLAGS += $(FPIC)
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
+
 $(eval $(call HostBuild))