ramips: adjust LZMA_TEXT_START for 32MB RAM devices
authorSungbo Eo <mans0n@gorani.run>
Tue, 4 Aug 2020 16:03:42 +0000 (01:03 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Aug 2020 14:13:51 +0000 (16:13 +0200)
Currently the lzma-loader is placed in RAM at 32MB offset, which does not
make sense for devices with only 32MB RAM. If we adjust LZMA_TEXT_START to
24MB offset, then the lzma-loader can be used on those devices and still
about 24MB memory will be available for uncompressed image, which should be
enough for most use cases.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ramips/image/Makefile

index c0890e6bb3a6de4357f3b4c05c084b7222708214..f5166f8ae1010183f982c3b788789d9b51c8b88d 100644 (file)
@@ -64,7 +64,7 @@ define Build/loader-common
                PKG_BUILD_DIR="$@.src" \
                TARGET_DIR="$(dir $@)" LOADER_NAME="$(notdir $@)" \
                BOARD="$(BOARDNAME)" PLATFORM="$(LOADER_PLATFORM)" \
-               LZMA_TEXT_START=0x82000000 LOADADDR=$(KERNEL_LOADADDR) \
+               LZMA_TEXT_START=0x81800000 LOADADDR=$(KERNEL_LOADADDR) \
                $(1) compile loader.$(LOADER_TYPE)
        mv "$@.$(LOADER_TYPE)" "$@"
        rm -rf $@.src