ramips: use proper name for RAVPower RP-WD03
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 11 Sep 2020 15:09:44 +0000 (17:09 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 11 Sep 2020 17:18:54 +0000 (19:18 +0200)
The proper model name is RP-WD03 (i.e. with the RP- prefix).

Adjust all names to that.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/dts/mt7620n_ravpower_rp-wd03.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7620n_ravpower_wd03.dts [deleted file]
target/linux/ramips/image/mt7620.mk
target/linux/ramips/mt7620/base-files/etc/board.d/02_network
target/linux/ramips/mt7620/base-files/etc/uci-defaults/04_led_migration

diff --git a/target/linux/ramips/dts/mt7620n_ravpower_rp-wd03.dts b/target/linux/ramips/dts/mt7620n_ravpower_rp-wd03.dts
new file mode 100644 (file)
index 0000000..31ecd4d
--- /dev/null
@@ -0,0 +1,114 @@
+/dts-v1/;
+
+#include "mt7620n.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "ravpower,rp-wd03", "ralink,mt7620n-soc";
+       model = "RAVPower RP-WD03";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               green-wifi {
+                       label = "rp-wd03:green:wifi";
+                       gpios = <&gpio2 0 GPIO_ACTIVE_HIGH>;
+               };
+
+               blue-wifi {
+                       label = "rp-wd03:blue:wifi";
+                       gpios = <&gpio3 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio2 1 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&gpio2 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&i2c {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x7b0000>;
+                       };
+               };
+       };
+};
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4000>;
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0x0>;
+};
+
+&state_default {
+       gpio {
+               groups = "wled", "ephy";
+               function = "gpio";
+       };
+};
diff --git a/target/linux/ramips/dts/mt7620n_ravpower_wd03.dts b/target/linux/ramips/dts/mt7620n_ravpower_wd03.dts
deleted file mode 100644 (file)
index f67f186..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-/dts-v1/;
-
-#include "mt7620n.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "ravpower,wd03", "ralink,mt7620n-soc";
-       model = "Ravpower WD03";
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               green-wifi {
-                       label = "wd03:green:wifi";
-                       gpios = <&gpio2 0 GPIO_ACTIVE_HIGH>;
-               };
-
-               blue-wifi {
-                       label = "wd03:blue:wifi";
-                       gpios = <&gpio3 0 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio2 1 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-};
-
-&gpio2 {
-       status = "okay";
-};
-
-&gpio3 {
-       status = "okay";
-};
-
-&i2c {
-       status = "okay";
-};
-
-&spi0 {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x50000 0x7b0000>;
-                       };
-               };
-       };
-};
-
-&ehci {
-       status = "okay";
-};
-
-&ohci {
-       status = "okay";
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0x4000>;
-};
-
-&wmac {
-       ralink,mtd-eeprom = <&factory 0x0>;
-};
-
-&state_default {
-       gpio {
-               groups = "wled", "ephy";
-               function = "gpio";
-       };
-};
index 5b9dd16bcea3106c275d3379545b953cd28b3f27..a3a468324ba7ab4cad04f67f6a0b777a81370cd9 100644 (file)
@@ -924,15 +924,16 @@ define Device/ralink_mt7620a-v22sg-evb
 endef
 TARGET_DEVICES += ralink_mt7620a-v22sg-evb
 
-define Device/ravpower_wd03
+define Device/ravpower_rp-wd03
   SOC := mt7620n
   IMAGE_SIZE := 7872k
-  DEVICE_VENDOR := Ravpower
-  DEVICE_MODEL := WD03
+  DEVICE_VENDOR := RAVPower
+  DEVICE_MODEL := RP-WD03
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+  SUPPORTED_DEVICES += ravpower,wd03
   DEFAULT := n
 endef
-TARGET_DEVICES += ravpower_wd03
+TARGET_DEVICES += ravpower_rp-wd03
 
 define Device/sanlinking_d240
   SOC := mt7620a
index 3c77e6ad30349b5686689e1b5d290d8fa2988fd4..3fdd42bbffb353f7aa5499e83ba3a1542ddf4835 100755 (executable)
@@ -60,7 +60,7 @@ ramips_setup_interfaces()
        planex,cs-qr10|\
        planex,mzk-ex300np|\
        planex,mzk-ex750np|\
-       ravpower,wd03|\
+       ravpower,rp-wd03|\
        sercomm,na930|\
        tplink,re200-v1|\
        tplink,re210-v1|\
index 16ccd5cfef2d429403c0094d6337884a3f332fe3..0f2e08cf7f354836d7e8b5b81b9c49ffd7134c26 100644 (file)
@@ -13,6 +13,9 @@ lenovo,newifi-y1s)
 netgear,wn3000rp-v3)
        migrate_leds "^wn3000rpv3:=wn3000rp-v3:"
        ;;
+ravpower,rp-wd03)
+       migrate_leds "^wd03:=rp-wd03:"
+       ;;
 tplink,archer-c2-v1)
        migrate_leds "^c2-v1:=archer-c2-v1:"
        ;;