brcm63xx: don't build non-dtb kernels anymore
authorJonas Gorski <jogo@openwrt.org>
Mon, 30 Mar 2015 20:21:24 +0000 (20:21 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 30 Mar 2015 20:21:24 +0000 (20:21 +0000)
Now that all supported boards have an dts there is no need for a
dtb free kernel anymore.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45169

target/linux/brcm63xx/image/Makefile

index ae84b1da09aacbda9289b825636257846180b4b4..6b8fa5514178dbcf944e58504f90617fbf21b219 100755 (executable)
@@ -205,12 +205,9 @@ define Image/Prepare
        $(CP) ../../generic/image/relocate $(KDIR)
        $(MAKE) -C $(KDIR)/relocate $(RELOCATE_MAKEOPTS)
 
-       $(call Image/PrepareCFELzmaKernel,)
-
        $(foreach board,$(sort $(TARGET_$(PROFILE)_DTBS)), $(call Image/PrepareCFELzmaKernelDTB,$(board)))
 
  ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-       $(call Image/PrepareLoader,-initramfs,$(BIN_DIR),loader.elf)
        $(foreach board,$(sort $(TARGET_$(PROFILE)_DTBS)), \
                $(call Image/PrepareLoaderDTB,-initramfs,$(board),$(BIN_DIR),loader.elf))
  ifneq (,$(findstring cvg834g,$(TARGET_$(PROFILE)_DTBS)))