mac80211: adapt for single-instance wpad
authorDaniel Golle <daniel@makrotopia.org>
Mon, 6 Apr 2020 23:00:11 +0000 (00:00 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 13 Apr 2020 23:22:21 +0000 (00:22 +0100)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh

index 8722172d04d07ce1db6cadd01bf03b27c3da52a9..d01b689260ec6ae2b2052f805b88338bf10e4101 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=5.4.27-1
 PKG_NAME:=mac80211
 
 PKG_VERSION:=5.4.27-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.4.27/
 PKG_HASH:=4c853a2f4c4fcc81cf60a3d59c5efbdb60c3e4acda22996cb192443581753950
 
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.4.27/
 PKG_HASH:=4c853a2f4c4fcc81cf60a3d59c5efbdb60c3e4acda22996cb192443581753950
 
index 7348db03544f6e361484332677147be85eaa873a..f9a60792dcfda47bb9e84305a2d83b2ae1486884 100644 (file)
@@ -594,11 +594,11 @@ mac80211_setup_supplicant() {
        NEWSPLIST="${NEWSPLIST}$ifname "
 
        if [ "${NEWAPLIST%% *}" != "${OLDAPLIST%% *}" ]; then
        NEWSPLIST="${NEWSPLIST}$ifname "
 
        if [ "${NEWAPLIST%% *}" != "${OLDAPLIST%% *}" ]; then
-               [ "$spobj" ] && ubus call wpa_supplicant.${phy} config_del "{\"iface\":\"$ifname\"}"
+               [ "$spobj" ] && ubus call wpa_supplicant config_remove "{\"iface\":\"$ifname\"}"
                add_sp=1
        fi
        [ "$enable" = 0 ] && {
                add_sp=1
        fi
        [ "$enable" = 0 ] && {
-               ubus call wpa_supplicant.${phy} config_del "{\"iface\":\"$ifname\"}"
+               ubus call wpa_supplicant config_remove "{\"iface\":\"$ifname\"}"
                ip link set dev "$ifname" down
                return 0
        }
                ip link set dev "$ifname" down
                return 0
        }
@@ -623,7 +623,7 @@ mac80211_setup_supplicant_noctl() {
 
        NEWSPLIST="${NEWSPLIST}$ifname "
        [ "$enable" = 0 ] && {
 
        NEWSPLIST="${NEWSPLIST}$ifname "
        [ "$enable" = 0 ] && {
-               ubus call wpa_supplicant.${phy} config_del "{\"iface\":\"$ifname\"}"
+               ubus call wpa_supplicant config_remove "{\"iface\":\"$ifname\"}"
                ip link set dev "$ifname" down
                return 0
        }
                ip link set dev "$ifname" down
                return 0
        }
@@ -814,7 +814,7 @@ mac80211_vap_cleanup() {
        local vaps="$2"
 
        for wdev in $vaps; do
        local vaps="$2"
 
        for wdev in $vaps; do
-               [ "$service" != "none" ] && ubus call ${service}.${phy} config_remove "{\"iface\":\"$wdev\"}"
+               [ "$service" != "none" ] && ubus call ${service} config_remove "{\"iface\":\"$wdev\"}"
                ip link set dev "$wdev" down 2>/dev/null
                iw dev "$wdev" del
        done
                ip link set dev "$wdev" down 2>/dev/null
                iw dev "$wdev" del
        done
@@ -962,9 +962,9 @@ drv_mac80211_setup() {
                fi
                if [ "$no_reload" != "0" ]; then
                        add_ap=1
                fi
                if [ "$no_reload" != "0" ]; then
                        add_ap=1
-                       ubus wait_for hostapd.$phy
-                       ubus call hostapd.${phy} config_add "{\"iface\":\"$primary_ap\", \"config\":\"${hostapd_conf_file}\"}"
-                       local hostapd_pid=$(ubus call service list '{"name": "hostapd"}' | jsonfilter -l 1 -e "@['hostapd'].instances['hostapd-${phy}'].pid")
+                       ubus wait_for hostapd
+                       ubus call hostapd config_add "{\"iface\":\"$primary_ap\", \"config\":\"${hostapd_conf_file}\"}"
+                       local hostapd_pid=$(ubus call service list '{"name": "hostapd"}' | jsonfilter -l 1 -e "@['hostapd'].instances['hostapd'].pid")
                        wireless_add_process "$hostapd_pid" "/usr/sbin/hostapd" 1
                fi
                ret="$?"
                        wireless_add_process "$hostapd_pid" "/usr/sbin/hostapd" 1
                fi
                ret="$?"