include/prereq-build.mk: explicitly check for -f flag when using busybox time
authorMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 14 Jul 2018 13:44:47 +0000 (15:44 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 14 Jul 2018 13:48:14 +0000 (15:48 +0200)
On Debian, busybox does have a time applet, but it does not support the -f
flag. Catch this in prereq check to give users to proper error message.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
(cherry picked from commit b123921a92a957f08abb186e041aa38aa9328f3e)

include/prereq-build.mk

index 72875aef4e67b0f20bf1ce63a770aacd9d0ad42e..edd63e9ee6821c80273756f423246f42fb5acc6d 100644 (file)
@@ -138,10 +138,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
-$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time', \
+$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time' that supports -f, \
        gtime --version 2>&1 | grep GNU, \
        time --version 2>&1 | grep GNU, \
-       busybox time 2>&1 | grep BusyBox))
+       busybox time 2>&1 | grep -- '-f FMT'))
 
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))