dnsmasq: restore ability to include/exclude raw device names
authorJo-Philipp Wich <jo@mein.io>
Mon, 10 Jul 2017 08:53:29 +0000 (10:53 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 10 Jul 2017 09:02:27 +0000 (11:02 +0200)
Commit 5cd88f4 "dnsmasq: remove use of uci state for getting network ifname"
broke the ability to specify unmanaged network device names for inclusion
and exclusion in the uci configuration.

Restore support for raw device names by falling back to the input value
when "network_get_device" yields no result.

Fixes FS#876.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dnsmasq.init

index 401071fe92a0af321c65b1185383b07f8150e32e..070172464e36caea0ee321c8ab580dbec0a61343 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.77
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.77
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
index 19517d937d451c9cbe889ef0ad3ba3024b342db7..6f985b2417c10c311e232e63bdc4dfc5766d5b98 100644 (file)
@@ -138,12 +138,12 @@ append_ipset() {
 }
 
 append_interface() {
 }
 
 append_interface() {
-       network_get_device ifname "$1" || return
+       network_get_device ifname "$1" || ifname="$1"
        xappend "--interface=$ifname"
 }
 
 append_notinterface() {
        xappend "--interface=$ifname"
 }
 
 append_notinterface() {
-       network_get_device ifname "$1" || return
+       network_get_device ifname "$1" || ifname="$1"
        xappend "--except-interface=$ifname"
 }
 
        xappend "--except-interface=$ifname"
 }