kernel: add rtc-ds1672 module support
authorLuka Perkov <luka@openwrt.org>
Tue, 17 Dec 2013 02:47:16 +0000 (02:47 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 17 Dec 2013 02:47:16 +0000 (02:47 +0000)
Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 39110

package/kernel/linux/modules/other.mk

index d8d437fa6243acddea10e0b986fe1111e51147ef..c1adc66c524e8b04356086d8c566adc2ea80eaad 100644 (file)
@@ -485,6 +485,23 @@ endef
 $(eval $(call KernelPackage,pwm-gpio))
 
 
+define KernelPackage/rtc-ds1672
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Dallas/Maxim DS1672 RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_DS1672
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1672.ko
+  AUTOLOAD:=$(call AutoProbe,rtc-ds1672)
+endef
+
+define KernelPackage/rtc-ds1672/description
+ Kernel module for Dallas/Maxim DS1672 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-ds1672))
+
+
 define KernelPackage/rtc-isl1208
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Intersil ISL1208 RTC support