ramips: add support for ELECOM WRC-1900GST
authorNOGUCHI Hiroshi <drvlabo@gmail.com>
Sat, 18 Aug 2018 23:05:15 +0000 (08:05 +0900)
committerMathias Kresin <dev@kresin.me>
Thu, 23 Aug 2018 20:42:09 +0000 (22:42 +0200)
ELECOM WRC-1900GST is a wireless router, based on Mediatek MT7621A.
This is almost same as WRC-2533GST except wireless specs.

Specifications:

  - SoC : MT7621A (four logical CPU cores)
  - RAM : 128MiB
  - ROM : 16MiB of SPI NOR-FLASH
  - wireless :
          5GHz : 3T3R up to 1300Mbps/11ac with MT7615
          2.4GHz : 3T3R up to 600Mbps/11n with MT7615
  - Ethernet : 5 ports, all ports is capable of 1000base-T
  - Ether switch : MT7530 (MT7621A built-in)
  - LEDs : 4 LEDs
  - buttons : 2 buttons and 1 slide-switch
  - UART : header is on PCB, 57600bps

Flash instruction using factory image:

 1. Connect the computer to the LAN port of WRC-1900GST
 2. Connect power cable to WRC-1900GST and turn on it
 3. Access to "https://192.168.2.1/" and open firmware update
    page ("ファームウェア更新")
 4. Select the OpenWrt factory image and click apply ("適用")
    button
 5. Wait ~150 seconds to complete flashing

Signed-off-by: NOGUCHI Hiroshi <drvlabo@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WRC-1900GST.dts [new file with mode: 0644]
target/linux/ramips/dts/WRC-2533GST.dts
target/linux/ramips/dts/elecom_wrc-gst.dtsi [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index b6f70ef50d9a08f68980bfc4db74014af24f5a3b..96801b172c1bb2f7bef8043f996f0a36243c965b 100755 (executable)
@@ -239,6 +239,7 @@ ramips_setup_interfaces()
        dir-860l-b1|\
        elecom,wrc-1167ghbk2-s|\
        elecom,wrc-2533gst|\
+       elecom,wrc-1900gst|\
        iodata,wn-ax1167gr|\
        iodata,wn-gx300gr)
                ucidef_add_switch "switch0" \
@@ -480,6 +481,7 @@ ramips_setup_macs()
                ;;
        elecom,wrc-1167ghbk2-s|\
        elecom,wrc-2533gst|\
+       elecom,wrc-1900gst|\
        sk-wb8)
                wan_mac=$(mtd_get_mac_binary factory 57350)
                ;;
index 78b75d4648e1af8d3289ce857a9f263d20f8967b..68deb672fc518e29a4d93e14dbf8a1017df1ebf9 100755 (executable)
@@ -56,6 +56,7 @@ platform_check_image() {
        e1700|\
        elecom,wrc-1167ghbk2-s|\
        elecom,wrc-2533gst|\
+       elecom,wrc-1900gst|\
        esr-9753|\
        ew1200|\
        ex2700|\
diff --git a/target/linux/ramips/dts/WRC-1900GST.dts b/target/linux/ramips/dts/WRC-1900GST.dts
new file mode 100644 (file)
index 0000000..550a27b
--- /dev/null
@@ -0,0 +1,9 @@
+/dts-v1/;
+
+#include "elecom_wrc-gst.dtsi"
+
+
+/ {
+       compatible = "elecom,wrc-1900gst", "mediatek,mt7621-soc";
+       model = "ELECOM WRC-1900GST";
+  };
index d4d47aa9a8dfbf531dd3b29a87aef499f8c1b8a4..7aecdccbf632d0045f434e1362ecaf16fdc4ec90 100644 (file)
@@ -1,179 +1,9 @@
 /dts-v1/;
 
-#include "mt7621.dtsi"
+#include "elecom_wrc-gst.dtsi"
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
 
 / {
        compatible = "elecom,wrc-2533gst", "mediatek,mt7621-soc";
        model = "ELECOM WRC-2533GST";
-
-       aliases {
-               led-status = &led_power_green;
-       };
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x8000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               led_power_green: power_green {
-                       label = "wrc-2533gst:green:power";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
-               };
-
-               power_blue {
-                       label = "wrc-2533gst:blue:power";
-                       gpios = <&gpio0 8 GPIO_ACTIVE_HIGH>;
-               };
-
-               wps {
-                       label = "wrc-2533gst:red:wps";
-                       gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
-               };
-
-               power_red {
-                       label = "wrc-2533gst:red:power";
-                       gpios = <&gpio0 16 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-
-               client {
-                       label = "client";
-                       gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-                       linux,input-type = <EV_SW>;
-               };
-
-               ap {
-                       label = "ap";
-                       gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-                       linux,input-type = <EV_SW>;
-               };
-
-               extender {
-                       label = "extender";
-                       gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-                       linux,input-type = <EV_SW>;
-               };
-
-               router {
-                       label = "router";
-                       gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-                       linux,input-type = <EV_SW>;
-               };
-       };
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0xe000>;
-};
-
-&spi0 {
-       status = "okay";
-
-       m25p80@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-               m25p,chunked-io = <32>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               label = "firmware";
-                               reg = <0x50000 0xb00000>;
-                       };
-
-                       partition@b50000 {
-                               label = "tm_pattern";
-                               reg = <0xb50000 0x380000>;
-                               read-only;
-                       };
-
-                       partition@ed0000 {
-                               label = "tm_key";
-                               reg = <0xed0000 0x80000>;
-                               read-only;
-                       };
-
-                       partition@f50000 {
-                               label = "art_block";
-                               reg = <0xf50000 0x30000>;
-                               read-only;
-                       };
-
-                       partition@f80000 {
-                               label = "user_data";
-                               reg = <0xf80000 0x80000>;
-                               read-only;
-                       };
-               };
-       };
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "uart3", "jtag", "wdt", "sdhci";
-                       ralink,function = "gpio";
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-       /* WRC-2533GST has MT7615 for 2.4/5 GHz wifi, but it's not supported */
-};
-
-&xhci {
-       status = "disabled";
-};
+  };
diff --git a/target/linux/ramips/dts/elecom_wrc-gst.dtsi b/target/linux/ramips/dts/elecom_wrc-gst.dtsi
new file mode 100644 (file)
index 0000000..6c52c1c
--- /dev/null
@@ -0,0 +1,176 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               led-status = &led_power_green;
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x8000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               led_power_green: power_green {
+                       label = "wrc-gst:green:power";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
+               };
+
+               power_blue {
+                       label = "wrc-gst:blue:power";
+                       gpios = <&gpio0 8 GPIO_ACTIVE_HIGH>;
+               };
+
+               wps {
+                       label = "wrc-gst:red:wps";
+                       gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
+               };
+
+               power_red {
+                       label = "wrc-gst:red:power";
+                       gpios = <&gpio0 16 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               client {
+                       label = "client";
+                       gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+
+               ap {
+                       label = "ap";
+                       gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+
+               extender {
+                       label = "extender";
+                       gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+
+               router {
+                       label = "router";
+                       gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+               m25p,chunked-io = <32>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x50000 0xb00000>;
+                       };
+
+                       partition@b50000 {
+                               label = "tm_pattern";
+                               reg = <0xb50000 0x380000>;
+                               read-only;
+                       };
+
+                       partition@ed0000 {
+                               label = "tm_key";
+                               reg = <0xed0000 0x80000>;
+                               read-only;
+                       };
+
+                       partition@f50000 {
+                               label = "art_block";
+                               reg = <0xf50000 0x30000>;
+                               read-only;
+                       };
+
+                       partition@f80000 {
+                               label = "user_data";
+                               reg = <0xf80000 0x80000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "uart3", "jtag", "wdt", "sdhci";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+       /* WRC-xxxxGST has MT7615 for 2.4/5 GHz wifi, but it's not supported */
+};
+
+&xhci {
+       status = "disabled";
+};
index b427ff4f25a6e50980a64a709c31ed99bb28cfd4..4195c2269192b10739863869479c777951574816 100644 (file)
@@ -127,6 +127,16 @@ define Device/elecom_wrc-2533gst
 endef
 TARGET_DEVICES += elecom_wrc-2533gst
 
+define Device/elecom_wrc-1900gst
+  DTS := WRC-1900GST
+  IMAGE_SIZE := 11264k
+  DEVICE_TITLE := ELECOM WRC-1900GST
+  IMAGES += factory.bin
+  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
+    elecom-gst-factory WRC-1900GST 0.00
+endef
+TARGET_DEVICES += elecom_wrc-1900gst
+
 define Device/ew1200
   DTS := EW1200
   IMAGE_SIZE := $(ralink_default_fw_size_16M)