build: move append-file to image-commands.mk
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>
Mon, 23 Jan 2017 13:40:10 +0000 (14:40 +0100)
committerMathias Kresin <dev@kresin.me>
Fri, 27 Jan 2017 10:10:10 +0000 (11:10 +0100)
Move it append-file to image-commands.mk so that it can used by other
targets as well.

Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
include/image-commands.mk
target/linux/ipq806x/image/Makefile

index 04fa853fbbd99936c547d5eb0862137cba22809d..e0f2918a3876af03ecbb09b5d6ffc6596d5b24fd 100644 (file)
@@ -110,6 +110,10 @@ define Build/append-rootfs
        dd if=$(IMAGE_ROOTFS) >> $@
 endef
 
+define Build/append-file
+       cat "$(1)" >> "$@"
+endef
+
 define Build/append-ubi
        sh $(TOPDIR)/scripts/ubinize-image.sh \
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \
index 3cc48bb905aa31ea57cf8af11e7cac3873a87eab..33dc31d41edab3d6d78230f82b6bba9678dba65e 100644 (file)
@@ -31,10 +31,6 @@ define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-root.img bs=2k conv=sync
 endef
 
-define Build/append-file
-       cat $(1) >> $@
-endef
-
 define Device/Default
        PROFILES := Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)