image.mk: include per-device profiles in image build profile check
authorFelix Fietkau <nbd@nbd.name>
Wed, 11 May 2016 17:15:23 +0000 (19:15 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 11 May 2016 17:19:17 +0000 (19:19 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image.mk

index ed4f8e44ea75c2fe271a04b8984be6069cbd6b52..67879b37805e308ddfbe6f760245479fd0e17dcd 100644 (file)
@@ -475,8 +475,8 @@ define Device/Export
 endef
 
 define Device/Check
-  _TARGET = $$(if $$(and $$(filter $(SUBTARGET),$$(SUBTARGETS)),$$(filter $(PROFILE),$$(PROFILES))),install,install-disabled)
-  _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES))),compile,compile-disabled)
+  _TARGET = $$(if $$(and $$(filter $(SUBTARGET),$$(SUBTARGETS)),$$(filter $(PROFILE),$$(PROFILES) DEVICE_$(1))),install,install-disabled)
+  _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES) DEVICE_$(1))),compile,compile-disabled)
 endef
 
 ifndef IB