ath79: ASUS RP-AC66 use flash till the end
authorTamas Balogh <tamasbalogh@hotmail.com>
Tue, 25 Jan 2022 13:16:37 +0000 (14:16 +0100)
committerSungbo Eo <mans0n@gorani.run>
Sat, 29 Jan 2022 16:16:14 +0000 (01:16 +0900)
This makes available the additional space,
which was occupied by OEM's jffs2 partition before:
"0x000000f80000-0x000001000000 : jffs2"

Reverting to the OEM firmware will also recover
this partition, i.e. it is not needed and can be
used by OpenWrt.

Signed-off-by: Tamas Balogh <tamasbalogh@hotmail.com>
target/linux/ath79/dts/qca9563_asus_rp-ac66.dts
target/linux/ath79/image/generic.mk

index 39c96127e685c584303d13526a9f980481f0cd9e..c4b648349707bbdf6f120fc994480209d649be66 100644 (file)
                        partition@60000 {
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x060000 0xf20000>;
+                               reg = <0x060000 0xfa0000>;
                        };
                };
        };
index 7cde28e85b038e54b7e7f43730fab0fc7642b42a..b3598a2000c9bf1adc8dc1f96f4ca5d3485f45a7 100644 (file)
@@ -334,7 +334,7 @@ define Device/asus_rp-ac66
   SOC := qca9563
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RP-AC66
-  IMAGE_SIZE := 15488k
+  IMAGE_SIZE := 16000k
   IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
        append-rootfs | pad-rootfs