Revert "ath79: add support for Ubiquiti NanoStation Loco M (XW)"
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 22 Feb 2020 20:25:07 +0000 (21:25 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 22 Feb 2020 20:25:07 +0000 (21:25 +0100)
This reverts commit 21bf718b8c3b0fe1f13807aa5db16a2fb4f48120.

Until the mdio-reset is solved, this is not ready for stable release.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts [deleted file]
target/linux/ath79/image/generic-ubnt.mk

index dd483c0526bf1c451f0ce75d75fbb622a111557f..f600c6f779e639d8777069f619325a491fe04eef 100755 (executable)
@@ -201,7 +201,6 @@ tplink,tl-wr842n-v2)
 ubnt,bullet-m|\
 ubnt,bullet-m-xw|\
 ubnt,nanostation-loco-m|\
 ubnt,bullet-m|\
 ubnt,bullet-m-xw|\
 ubnt,nanostation-loco-m|\
-ubnt,nanostation-loco-m-xw|\
 ubnt,nanostation-m|\
 ubnt,nanostation-m-xw|\
 ubnt,picostation-m|\
 ubnt,nanostation-m|\
 ubnt,nanostation-m-xw|\
 ubnt,picostation-m|\
index c985a823c48fba67fe701efd2ef47b4721bc6071..3df6fde229c907ea3a8351f737edf3b7478694d1 100755 (executable)
@@ -39,7 +39,6 @@ ath79_setup_interfaces()
        ubnt,nanobeam-ac|\
        ubnt,nanostation-ac-loco|\
        ubnt,nanostation-loco-m|\
        ubnt,nanobeam-ac|\
        ubnt,nanostation-ac-loco|\
        ubnt,nanostation-loco-m|\
-       ubnt,nanostation-loco-m-xw|\
        ubnt,picostation-m|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
        ubnt,picostation-m|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts
deleted file mode 100644 (file)
index 8fb05ed..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9342_ubnt_xw.dtsi"
-
-/ {
-       compatible = "ubnt,nanostation-loco-m-xw", "ubnt,xw", "qca,ar9342";
-       model = "Ubiquiti Nanostation Loco M (XW)";
-};
-
-&mdio0 {
-       status = "okay";
-
-       phy-mask = <0x1>;
-
-       phy1: ethernet-phy@1 {
-               reg = <1>;
-               phy-mode = "mii";
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       phy-handle = <&phy1>;
-};
index f34ffa1612ec3e97bf239fa07ae40c669e6dc6d9..1ae16554bc3f95580cbc8aea5d732c97a1a036ed 100644 (file)
@@ -125,14 +125,6 @@ define Device/ubnt_nanostation-loco-m
 endef
 TARGET_DEVICES += ubnt_nanostation-loco-m
 
 endef
 TARGET_DEVICES += ubnt_nanostation-loco-m
 
-define Device/ubnt_nanostation-loco-m-xw
-  $(Device/ubnt-xw)
-  DEVICE_TITLE := Ubiquiti Nanostation Loco M (XW)
-  DEVICE_PACKAGES += rssileds
-  SUPPORTED_DEVICES += loco-m-xw
-endef
-TARGET_DEVICES += ubnt_nanostation-loco-m-xw
-
 define Device/ubnt_nanostation-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Nanostation M
 define Device/ubnt_nanostation-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Nanostation M