dnsmasq: add dhcp-script hook for other packages
authorNick Brassel <nick@tzarc.org>
Sat, 6 May 2017 10:56:26 +0000 (20:56 +1000)
committerHans Dedecker <dedeckeh@gmail.com>
Fri, 26 May 2017 19:28:30 +0000 (21:28 +0200)
Adds a script which acts as a hook for when dnsmasq creates/destroys a
lease, or completes a TFTP file transfer. The hook loops through scripts
in appropriate directories inside '/etc/hotplug.d', executing each one with
the same arguments supplied by dnsmasq.

In case dnsmasq is jailed by ujail the dhcp-script hook will not work as
expected as ujail does not yet support executing a script within a jail.

Signed-off-by: Nick Brassel <nick@tzarc.org>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dhcp-script.sh [new file with mode: 0755]
package/network/services/dnsmasq/files/dnsmasq.init

index 39df9e95e2bd18c9d35cc67c081789d90cbfc5e4..c67e26151e1119f46511c8b624365a7315fd00ba 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.77rc5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/release-candidates
@@ -150,10 +150,15 @@ define Package/dnsmasq/install
        $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/dhcp
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/neigh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/ntp
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/tftp
        $(INSTALL_DATA) ./files/dnsmasqsec.hotplug $(1)/etc/hotplug.d/ntp/25-dnsmasqsec
        $(INSTALL_DIR) $(1)/usr/share/dnsmasq
        $(INSTALL_DATA) ./files/rfc6761.conf $(1)/usr/share/dnsmasq/
+       $(INSTALL_DIR) $(1)/usr/lib/dnsmasq
+       $(INSTALL_BIN) ./files/dhcp-script.sh $(1)/usr/lib/dnsmasq/dhcp-script.sh
 endef
 
 Package/dnsmasq-dhcpv6/install = $(Package/dnsmasq/install)
diff --git a/package/network/services/dnsmasq/files/dhcp-script.sh b/package/network/services/dnsmasq/files/dhcp-script.sh
new file mode 100755 (executable)
index 0000000..8603269
--- /dev/null
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+[ -f "$USER_DHCPSCRIPT" ] && . "$USER_DHCPSCRIPT" "$@"
+
+case "$1" in
+       add)
+               export ACTION="add"
+               export MACADDR="$2"
+               export IPADDR="$3"
+               export HOSTNAME="$4"
+               exec /sbin/hotplug-call dhcp
+       ;;
+       del)
+               export ACTION="remove"
+               export MACADDR="$2"
+               export IPADDR="$3"
+               export HOSTNAME="$4"
+               exec /sbin/hotplug-call dhcp
+       ;;
+       old)
+               export ACTION="update"
+               export MACADDR="$2"
+               export IPADDR="$3"
+               export HOSTNAME="$4"
+               exec /sbin/hotplug-call dhcp
+       ;;
+       arp-add)
+               export ACTION="add"
+               export MACADDR="$2"
+               export IPADDR="$3"
+               exec /sbin/hotplug-call neigh
+       ;;
+       arp-del)
+               export ACTION="remove"
+               export MACADDR="$2"
+               export IPADDR="$3"
+               exec /sbin/hotplug-call neigh
+       ;;
+       tftp)
+               export ACTION="add"
+               export TFTP_SIZE="$2"
+               export TFTP_ADDR="$3"
+               export TFTP_PATH="$4"
+               exec /sbin/hotplug-call tftp
+       ;;
+esac
index 5221db46f627cfebe044bba2989188c070ed44fb..62a3169c6787e560b8321b048dd6a2c5a86bb6a0 100644 (file)
@@ -18,6 +18,7 @@ TRUSTANCHORSFILE="/usr/share/dnsmasq/trust-anchors.conf"
 TIMEVALIDFILE="/var/state/dnsmasqsec"
 BASEDHCPSTAMPFILE="/var/run/dnsmasq"
 RFC6761FILE="/usr/share/dnsmasq/rfc6761.conf"
+DHCPSCRIPT="/usr/lib/dnsmasq/dhcp-script.sh"
 
 DNSMASQ_DHCP_VER=4
 
@@ -696,7 +697,7 @@ dhcp_relay_add() {
 
 dnsmasq_start()
 {
-       local cfg="$1" disabled resolvfile
+       local cfg="$1" disabled resolvfile user_dhcpscript
 
        config_get_bool disabled "$cfg" disabled 0
        [ "$disabled" -gt 0 ] && return 0
@@ -791,7 +792,7 @@ dnsmasq_start()
        append_bool "$cfg" noping "--no-ping"
 
        append_parm "$cfg" logfacility "--log-facility"
-       append_parm "$cfg" dhcpscript "--dhcp-script"
+
        append_parm "$cfg" cachesize "--cache-size"
        append_parm "$cfg" dnsforwardmax "--dns-forward-max"
        append_parm "$cfg" port "--port"
@@ -831,7 +832,8 @@ dnsmasq_start()
        config_get_bool readethers "$cfg" readethers
        [ "$readethers" = "1" -a \! -e "/etc/ethers" ] && touch /etc/ethers
 
-       config_get dhcpscript $cfg dhcpscript
+       xappend "--dhcp-script=$DHCPSCRIPT"
+       config_get user_dhcpscript $cfg dhcpscript
 
        config_get leasefile $cfg leasefile "/tmp/dhcp.leases"
        [ -n "$leasefile" -a \! -e "$leasefile" ] && touch "$leasefile"
@@ -971,6 +973,7 @@ dnsmasq_start()
        procd_open_instance $cfg
        procd_set_param command $PROG -C $CONFIGFILE -k -x /var/run/dnsmasq/dnsmasq."${cfg}".pid
        procd_set_param file $CONFIGFILE
+       [ -n "$user_dhcpscript" ] && procd_set_param env USER_DHCPSCRIPT="$user_dhcpscript"
        procd_set_param respawn
 
        local dnsmasqconffile="/etc/dnsmasq.${cfg}.conf"
@@ -979,7 +982,7 @@ dnsmasq_start()
        fi
 
        procd_add_jail dnsmasq ubus log
-       procd_add_jail_mount $CONFIGFILE $TRUSTANCHORSFILE $HOSTFILE $RFC6761FILE /etc/passwd /etc/group /etc/TZ /dev/null /dev/urandom $dnsmasqconffile $dnsmasqconfdir $resolvfile $dhcpscript /etc/hosts /etc/ethers $EXTRA_MOUNT
+       procd_add_jail_mount $CONFIGFILE $TRUSTANCHORSFILE $HOSTFILE $RFC6761FILE /etc/passwd /etc/group /etc/TZ /dev/null /dev/urandom $dnsmasqconffile $dnsmasqconfdir $resolvfile $user_dhcpscript /etc/hosts /etc/ethers /sbin/hotplug-call $EXTRA_MOUNT $DHCPSCRIPT
        procd_add_jail_mount_rw /var/run/dnsmasq/ $leasefile
 
        procd_close_instance