mediatek: add FEATURES and order them alphabetically
authorDaniel Golle <daniel@makrotopia.org>
Wed, 15 Sep 2021 18:10:46 +0000 (19:10 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 30 Sep 2021 21:52:12 +0000 (22:52 +0100)
Add common features 'gpio', 'nand', 'pci', 'pcie', 'squashfs' and 'usb'
for all mediatek targets, add 'display' and 'usbgadget' for MT7623.
Sort features alphabetically while at it.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/Makefile
target/linux/mediatek/mt7623/target.mk

index 94a7dfbdc148c89230bcdab8f8127cceb5f06619..d42d0eacd723deee4e3feb7c70ad3c5d5eeb1f2d 100644 (file)
@@ -6,7 +6,7 @@ ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 SUBTARGETS:=mt7622 mt7623 mt7629
-FEATURES:=squashfs nand separate_ramdisk fpu dt-overlay
+FEATURES:=dt-overlay fpu gpio nand pci pcie separate_ramdisk squashfs usb
 
 KERNEL_PATCHVER:=5.10
 
index a9d6d2aea1b3a6f486565326eb0f056d0b38c007..ad05367f86459780d06f9abce8b9c7ac95897e38 100644 (file)
@@ -8,7 +8,7 @@ BOARDNAME:=MT7623
 CPU_TYPE:=cortex-a7
 CPU_SUBTYPE:=neon-vfpv4
 KERNELNAME:=Image dtbs zImage
-FEATURES+=usb
+FEATURES+=display usbgadget
 DEFAULT_PACKAGES+=blockdev uboot-envtools
 
 define Target/Description