ramips: harmonize device vendor Zbtlink
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 26 Sep 2019 12:44:22 +0000 (14:44 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 28 Sep 2019 22:08:20 +0000 (00:08 +0200)
Spelling of Zbtlink varies across image definitions and DTS files.

This patch uses Zbtlink consistently and also updates the model
in DTS files to contain the vendor in all cases.

This patch is cosmetical, as there should be no dependencies on
device model name in ramips anymore.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
12 files changed:
target/linux/ramips/dts/mt7620a_zbtlink_we1026-5g-16m.dts
target/linux/ramips/dts/mt7620a_zbtlink_zbt-ape522ii.dts
target/linux/ramips/dts/mt7620a_zbtlink_zbt-we826-16m.dts
target/linux/ramips/dts/mt7620a_zbtlink_zbt-we826-32m.dts
target/linux/ramips/dts/mt7620a_zbtlink_zbt-we826-e.dts
target/linux/ramips/dts/mt7621_zbtlink_zbt-we1326.dts
target/linux/ramips/dts/mt7621_zbtlink_zbt-we3526.dts
target/linux/ramips/dts/mt7621_zbtlink_zbt-wg2626.dts
target/linux/ramips/dts/mt7621_zbtlink_zbt-wg3526-16m.dts
target/linux/ramips/dts/mt7621_zbtlink_zbt-wg3526-32m.dts
target/linux/ramips/image/mt7621.mk
target/linux/ramips/image/mt76x8.mk

index e2eb5b632922a71ce6da1f80bff416ced6852b98..a05e8d4b4791d8c51dd23baec0edeef2393cdfbe 100644 (file)
@@ -37,7 +37,7 @@
 
 / {
        compatible = "zbtlink,we1026-5g-16m", "ralink,mt7620a-soc";
-       model = "ZBT WE1026-5G (16M)";
+       model = "Zbtlink ZBT-WE1026-5G (16M)";
 };
 
 &spi0 {
index 70ad0f0b58555a2ccd27b90d758976a948863fb3..665dd5ba3c11d8e9dd3b8e157622c62eb1724db5 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "zbtlink,zbt-ape522ii", "ralink,mt7620a-soc";
-       model = "ZBT-APE522II";
+       model = "Zbtlink ZBT-APE522II";
 
        chosen {
                bootargs = "console=ttyS0,115200";
index 7f2b2646b223f3b932b105330f93b52aa376e623..d115b8a096e23f11f699923ede6e7825a3f0ff4c 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "zbtlink,zbt-we826-16m", "zbtlink,zbt-we826", "ralink,mt7620a-soc";
-       model = "ZBT-WE826 (16M)";
+       model = "Zbtlink ZBT-WE826 (16M)";
 };
 
 &spi0 {
index e7cdcab5e96e8844bff50842005bc83640ff4d52..94a67dd5def1e90bf7460a5a661eb34148738e33 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "zbtlink,zbt-we826-32m", "zbtlink,zbt-we826", "ralink,mt7620a-soc";
-       model = "ZBT-WE826 (32M)";
+       model = "Zbtlink ZBT-WE826 (32M)";
 };
 
 &spi0 {
index 243126125ba3a263487eb011c6158f627e7d3338..2496a16a29660609a4d19ed86ff551953456e2e0 100644 (file)
@@ -5,7 +5,7 @@
 
 / {
        compatible = "zbtlink,zbt-we826-e", "zbtlink,zbt-we826", "ralink,mt7620a-soc";
-       model = "ZBT-WE826-E";
+       model = "Zbtlink ZBT-WE826-E";
 
        /delete-node/ leds;
 
index 819c851c733544ea7a848be1d31376d7775c3646..d7c48c6d9ff3eff88e3dbedfb5fa24554af8dd8e 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "zbtlink,zbt-we1326", "mediatek,mt7621-soc";
-       model = "ZBT-WE1326";
+       model = "Zbtlink ZBT-WE1326";
 
        aliases {
                label-mac-device = &wifi1;
index 7973626fadebf8d5dccf79cefccde1d6087d6507..b1d3e4e81252f00aae93fd4cd4466275c70ba7e7 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "zbtlink,zbt-we3526", "mediatek,mt7621-soc";
-       model = "ZBT-WE3526";
+       model = "Zbtlink ZBT-WE3526";
 
        chosen {
                bootargs = "console=ttyS0,115200";
index ca2044f73ee6066d9e9217ee952882fbff550918..1a2a89a31e86b787efbed6180c74d12c676ba3dd 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "zbtlink,zbt-wg2626", "mediatek,mt7621-soc";
-       model = "ZBT-WG2626";
+       model = "Zbtlink ZBT-WG2626";
 
        aliases {
                led-boot = &led_status;
index 9bf8b9bdb26474845b9ac426ecb2c645a5d7f333..a9bd9180fd20468ed0d631a3c2c0903bf5131976 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "zbtlink,zbt-wg3526-16m", "zbtlink,zbt-wg3526", "mediatek,mt7621-soc";
-       model = "ZBT-WG3526 (16M)";
+       model = "Zbtlink ZBT-WG3526 (16M)";
 };
 
 &firmware {
index 8e49e48b2b4e42da2a9d05a8a4eaf1cfeb8ed469..e7add46d329f22481a2df813ed621193391ce0ab 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "zbtlink,zbt-wg3526-32m", "zbtlink,zbt-wg3526", "mediatek,mt7621-soc";
-       model = "ZBT-WG3526 (32M)";
+       model = "Zbtlink ZBT-WG3526 (32M)";
 };
 
 &firmware {
index 816652ddaae8cf15dcd48f839bd6222d3b88091a..582fe3284e81d6678c2c6f9a7b204c3ba57dfe62 100644 (file)
@@ -805,7 +805,7 @@ TARGET_DEVICES += youku_yk-l2
 define Device/zbtlink_zbt-we1326
   MTK_SOC := mt7621
   IMAGE_SIZE := 16064k
-  DEVICE_VENDOR := ZBT
+  DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WE1326
   DEVICE_PACKAGES := \
        kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-sdhci-mt7620 wpad-basic
@@ -816,7 +816,7 @@ TARGET_DEVICES += zbtlink_zbt-we1326
 define Device/zbtlink_zbt-we3526
   MTK_SOC := mt7621
   IMAGE_SIZE := 16064k
-  DEVICE_VENDOR := ZBT
+  DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WE3526
   DEVICE_PACKAGES := \
        kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
@@ -827,7 +827,7 @@ TARGET_DEVICES += zbtlink_zbt-we3526
 define Device/zbtlink_zbt-wg2626
   MTK_SOC := mt7621
   IMAGE_SIZE := 16064k
-  DEVICE_VENDOR := ZBT
+  DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WG2626
   DEVICE_PACKAGES := \
        kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3 \
@@ -839,7 +839,7 @@ TARGET_DEVICES += zbtlink_zbt-wg2626
 define Device/zbtlink_zbt-wg3526-16m
   MTK_SOC := mt7621
   IMAGE_SIZE := 16064k
-  DEVICE_VENDOR := ZBT
+  DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WG3526
   DEVICE_VARIANT := 16M
   DEVICE_PACKAGES := \
@@ -852,7 +852,7 @@ TARGET_DEVICES += zbtlink_zbt-wg3526-16m
 define Device/zbtlink_zbt-wg3526-32m
   MTK_SOC := mt7621
   IMAGE_SIZE := 32448k
-  DEVICE_VENDOR := ZBT
+  DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WG3526
   DEVICE_VARIANT := 32M
   DEVICE_PACKAGES := \
index 3179adc4723b7749c67b4da99452618f0e4336a2..9ab16db06432a8010438c4853e60943fa58d8cf1 100644 (file)
@@ -578,7 +578,7 @@ TARGET_DEVICES += xiaomi_miwifi-nano
 define Device/zbtlink_zbt-we1226
   MTK_SOC := mt7628an
   IMAGE_SIZE := 7872k
-  DEVICE_VENDOR := ZBTlink
+  DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WE1226
 endef
 TARGET_DEVICES += zbtlink_zbt-we1226