uboot-at91: fix -Wformat-security
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>
Wed, 14 Aug 2019 00:42:14 +0000 (00:42 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Aug 2019 21:08:10 +0000 (23:08 +0200)
add patch to fix -Wformat-security warnings.

Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
package/boot/uboot-at91/Makefile
package/boot/uboot-at91/patches/001-fix-Wformat-security.patch [new file with mode: 0644]

index c17f1e04bf72b7715672d200fe3fae4abc3b928e..547b72f8d9b2c6e67636ebe4f5e99ab7f2f871f6 100644 (file)
@@ -131,7 +131,7 @@ UBOOT_TARGETS := \
 define Build/Compile
   +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
      CROSS_COMPILE=$(TARGET_CROSS) \
-        DTC=$(LINUX_DIR)/scripts/dtc/dtc \
+        DTC=$(PKG_BUILD_DIR)/scripts/dtc/dtc \
      KCFLAGS="$(filter-out -fstack-protector \
       -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
 endef
diff --git a/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch b/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
new file mode 100644 (file)
index 0000000..18f9af7
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/cmd/version.c b/cmd/version.c
+index b2fffe9..bcbbeb1 100644
+--- a/cmd/version.c
++++ b/cmd/version.c
+@@ -18,7 +18,7 @@ static int do_version(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
+ {
+       char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
+
+-      printf(display_options_get_banner(false, buf, sizeof(buf)));
++      printf("%s",display_options_get_banner(false, buf, sizeof(buf)));
+ #ifdef CC_VERSION_STRING
+       puts(CC_VERSION_STRING "\n");
+ #endif