linux: add missing dependencies to kmod-ip6tables
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 18 Jul 2013 11:57:19 +0000 (11:57 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 18 Jul 2013 11:57:19 +0000 (11:57 +0000)
SVN-Revision: 37389

package/kernel/linux/modules/netfilter.mk

index 4e4c85f45c41a560fdf4e4cad4fac2c3048b8263..ed02a437f195e161ef4903d4c2eae10a4f80acd0 100644 (file)
@@ -390,7 +390,7 @@ $(eval $(call KernelPackage,ipt-extra))
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
-  DEPENDS:=+kmod-ipv6
+  DEPENDS:=+kmod-ipv6 +kmod-ipt-core +kmod-ipt-conntrack
   KCONFIG:=$(KCONFIG_IPT_IPV6)
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))
   KCONFIG:=$(KCONFIG_IPT_IPV6)
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))