odhcp6c: add a odhcp6c.user placeholder script
authorRui Salvaterra <rsalvaterra@gmail.com>
Tue, 9 Mar 2021 22:16:05 +0000 (22:16 +0000)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 10 Mar 2021 19:16:06 +0000 (20:16 +0100)
Document the existence of this feature. This allows the user to execute a script
at each DHCPv6 event. This is useful, for example, as an ad-hoc way to update a
DDNS entry when (and only when) required.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/odhcp6c.user [new file with mode: 0644]

index c9eaaedb1936d1056448f65d60332d4b486a1594..b3b2ea11fb1fb30d46bc401a4e7f308680b7a7e8 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_RELEASE:=16
+PKG_RELEASE:=17
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
@@ -42,12 +42,18 @@ define Package/odhcp6c/config
     default 0
 endef
 
+define Package/odhcp6c/conffiles
+/etc/odhcp6c.user
+endef
+
 define Package/odhcp6c/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/odhcp6c $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/dhcpv6.sh $(1)/lib/netifd/proto/dhcpv6.sh
        $(INSTALL_BIN) ./files/dhcpv6.script $(1)/lib/netifd/
+       $(INSTALL_DIR) $(1)/etc/
+       $(INSTALL_CONF) ./files/odhcp6c.user $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,odhcp6c))
diff --git a/package/network/ipv6/odhcp6c/files/odhcp6c.user b/package/network/ipv6/odhcp6c/files/odhcp6c.user
new file mode 100644 (file)
index 0000000..f15a1b1
--- /dev/null
@@ -0,0 +1 @@
+# This script is sourced by odhcp6c's dhcpv6.script at every DHCPv6 event.