uhttpd: use configured distribution name for SSL certificate CN
authorFelix Fietkau <nbd@nbd.name>
Sat, 21 May 2016 10:42:44 +0000 (12:42 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sat, 21 May 2016 10:42:44 +0000 (12:42 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/uhttpd.config

index da5572b5fe5907192f73fa4271460234657784a3..ab5ef64bb560cbcd1779203b08a116446eda8a84 100644 (file)
@@ -23,6 +23,7 @@ PKG_BUILD_DEPENDS = ustream-ssl
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
+include $(INCLUDE_DIR)/version.mk
 
 define Package/uhttpd/default
   SECTION:=net
@@ -124,6 +125,7 @@ define Package/uhttpd/install
        $(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
+       $(VERSION_SED_SCRIPT) $(1)/etc/config/uhttpd
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
 endef
index f8df4cdecbe2f9c47dc3ec4f0cae311bdd31fc71..db57095d12499c949d9c60baf1ec092352ead6d0 100644 (file)
@@ -119,4 +119,4 @@ config cert px5g
        option location         Unknown
 
        # Common name
-       option commonname       Lede
+       option commonname       '%D'