realtek: Fix tc default package
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 21:32:08 +0000 (22:32 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 29 Mar 2022 12:28:21 +0000 (14:28 +0200)
The tc package does not exits any more, it was split into tc-tiny,
tc-full and tc-bpf. Include tc-bpf by default into realtek images.

This increases the compressed image size by about 232KBytes.

Tested-by: Stijn Segers <foss@volatilesystems.org>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 34fb36e165d5b6e6e37d33b4b0da789a8f1430bb)

target/linux/realtek/Makefile

index 8bed3d8a7232897e731b26931eb762c3e6ca3c85..037ba7ac7db893b6cc9907c5f3492cc21662f3dc 100644 (file)
@@ -19,6 +19,6 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
        firewall4 nftables kmod-nft-offload odhcp6c \
-       ip-full ip-bridge tc
+       ip-full ip-bridge tc-bpf
 
 $(eval $(call BuildTarget))