uboot-imx: set BUILD_SUBTARGET to 'cortexa9'
authorPiotr Dymacz <pepe2k@gmail.com>
Sun, 28 Mar 2021 22:48:15 +0000 (00:48 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Wed, 3 Nov 2021 11:45:40 +0000 (12:45 +0100)
All currently supported devices belong to the imx/cortexa9 subtarget.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
package/boot/uboot-imx/Makefile

index 9ca4d55a1cb097c786726c8c3817a5ee2b7d5145..2faa48bd7367eb5f112ee454169446252c8c1437 100644 (file)
@@ -24,6 +24,7 @@ define U-Boot/apalis_imx6
   NAME:=Toradex Apalis
   UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
   UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=toradex_apalis
 endef
 
@@ -31,11 +32,13 @@ define U-Boot/mx6cuboxi
   NAME:=SolidRun Cubox-i boards
   UBOOT_IMAGE:=SPL u-boot.img
   UBOOT_MAKE_FLAGS:=SPL u-boot.img
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=solidrun_cubox-i
 endef
 
 define U-Boot/wandboard
   NAME:=Wandboard Dual Lite/Quad/Solo
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=wandboard_dual
 endef