kernel: add iscsi-initator support
authorLucian Cristian <lucian.cristian@gmail.com>
Sun, 12 Apr 2020 14:45:41 +0000 (17:45 +0300)
committerPetr Štetiar <ynezz@true.cz>
Wed, 8 Jul 2020 14:07:05 +0000 (16:07 +0200)
Module is needed for using iscsi-initiator userspace applications

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
[added missing newline between kernel modules]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/linux/modules/block.mk

index b870304ad48b37ace15be5a65ff70bf187e9fe74..a86c60da2acf237ad9a3a7b709f61a464a1c57a7 100644 (file)
@@ -270,6 +270,32 @@ endef
 $(eval $(call KernelPackage,dm-raid))
 
 
+define KernelPackage/iscsi-initiator
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=iSCSI Initiator over TCP/IP
+  DEPENDS:=+kmod-scsi-core
+  KCONFIG:= \
+       CONFIG_INET \
+       CONFIG_SCSI_LOWLEVEL \
+       CONFIG_ISCSI_TCP \
+       CONFIG_SCSI_ISCSI_ATTRS
+  FILES:= \
+       $(LINUX_DIR)/drivers/scsi/iscsi_tcp.ko \
+       $(LINUX_DIR)/drivers/scsi/libiscsi.ko \
+       $(LINUX_DIR)/drivers/scsi/libiscsi_tcp.ko \
+       $(LINUX_DIR)/drivers/scsi/scsi_transport_iscsi.ko
+  AUTOLOAD:=$(call AutoProbe,libiscsi libiscsi_tcp scsi_transport_iscsi iscsi_tcp)
+endef
+
+define KernelPackage/iscsi-initiator/description
+The iSCSI Driver provides a host with the ability to access storage through an
+IP network. The driver uses the iSCSI protocol to transport SCSI requests and
+responses over a TCP/IP network between the host (the "initiator") and "targets".
+endef
+
+$(eval $(call KernelPackage,iscsi-initiator))
+
+
 define KernelPackage/md-mod
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=MD RAID