ustream-ssl: fix SNI when building against cyassl
authorNicolas Thill <nico@openwrt.org>
Wed, 1 Apr 2015 15:11:38 +0000 (15:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 1 Apr 2015 15:11:38 +0000 (15:11 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 45224

package/libs/ustream-ssl/Makefile

index abe74ca4d68421aca645f9e7ee3f3f428d123f37..b5e0b23dd9c9fc1014c61e6b18ccd09293b01dce 100644 (file)
@@ -52,8 +52,8 @@ define Package/libustream-polarssl
 endef
 
 ifeq ($(BUILD_VARIANT),cyassl)
 endef
 
 ifeq ($(BUILD_VARIANT),cyassl)
-  TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/cyassl
-  CMAKE_OPTIONS += -DCYASSL=on -DHAVE_SNI
+  TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/cyassl -DHAVE_SNI
+  CMAKE_OPTIONS += -DCYASSL=on
 endif
 ifeq ($(BUILD_VARIANT),polarssl)
   CMAKE_OPTIONS += -DPOLARSSL=on
 endif
 ifeq ($(BUILD_VARIANT),polarssl)
   CMAKE_OPTIONS += -DPOLARSSL=on