mvebu: udpu: include LM75 kmod by default
authorRobert Marko <robert.marko@sartura.hr>
Mon, 21 Mar 2022 10:47:28 +0000 (11:47 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 24 Mar 2022 07:19:47 +0000 (08:19 +0100)
uDPU has 2 LM75 compatible temperature sensors, so include the driver for
them by default in order to utilize them.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
(cherry picked from commit a8b2d3590329386d0ae6873460b2d5126f63ddaa)

target/linux/mvebu/image/cortexa53.mk

index ca3a53f992c052e265799a4e75b097b90da96ffd..dd9d1b379da07602c0ce12cedf1fadab896d6960 100644 (file)
@@ -85,7 +85,7 @@ define Device/methode_udpu
   KERNEL_LOADADDR := 0x00080000
   KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
   KERNEL_INITRAMFS_SUFFIX := .itb
-  DEVICE_PACKAGES += f2fs-tools fdisk kmod-i2c-pxa
+  DEVICE_PACKAGES += f2fs-tools fdisk kmod-i2c-pxa kmod-hwmon-lm75
   DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(2)
   IMAGES := firmware.tgz
   IMAGE/firmware.tgz := boot-scr | boot-img-ext4 | uDPU-firmware | append-metadata