fix image create after the conversion to subtargets
authorFlorian Fainelli <florian@openwrt.org>
Sun, 15 Nov 2009 13:10:44 +0000 (13:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 15 Nov 2009 13:10:44 +0000 (13:10 +0000)
SVN-Revision: 18424

target/linux/rdc/image/Makefile

index 315d917473cde5d3498e33218b4a7915d25cb0ad..6f960ac5610468ad18202a67f4ed1de1d6499c53 100644 (file)
@@ -98,7 +98,7 @@ endef
 
 define Image/Build
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD).bzImage
-       $(call Image/Build/$(PROFILE),$(1),$(PROFILE),$(patsubst jffs2-%k,%,$(1)))
+       $(call Image/Build/$(SUBTARGET),$(1),$(SUBTARGET),$(patsubst jffs2-%k,%,$(1)))
 ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
        $(call Image/Build/Initramfs)
 endif