curl: add flags to allow gc-sections to strip out unused code
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2016 12:51:57 +0000 (12:51 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2016 12:51:57 +0000 (12:51 +0000)
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 49184

package/network/utils/curl/Makefile

index 319c0b710d2b4ead9492ab2bd6cb5c61c2fd7870..af38ed4aed662f4ceaa1d7087606e3b9dd82f313 100644 (file)
@@ -99,8 +99,9 @@ define Package/libcurl/config
   source "$(SOURCE)/Config.in"
 endef
 
   source "$(SOURCE)/Config.in"
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
 TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
 TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_ARGS += \
        --disable-debug \
 
 CONFIGURE_ARGS += \
        --disable-debug \