kernel: support for Realtek USB bluetooth devices
authorQuintin Hill <stuff@quintin.me.uk>
Sat, 22 Oct 2022 07:14:42 +0000 (08:14 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Nov 2022 16:05:13 +0000 (17:05 +0100)
USB adaptors with the RTL8761B chipset are cheap and readily available
but so far support is missing in Openwrt.  Enable the relevant kernel
options and add a module to the kmod-bluetooth package.  Increases size
of kmod-bluetooth ipk from 279140 bytes to 285320 bytes on my ath79 build.

Tested on a WNDR3700v4 with rtl8761bu firmware.

Signed-off-by: Quintin Hill <stuff@quintin.me.uk>
package/kernel/linux/modules/other.mk

index 46f5dea7aeb2ed783a4e19b8c96fe844a773c667..58dd2d6c25f161e6997d91902b5d73d30c07028e 100644 (file)
@@ -41,7 +41,7 @@ define KernelPackage/bluetooth
        CONFIG_BT_HCIBTUSB \
        CONFIG_BT_HCIBTUSB_BCM=n \
        CONFIG_BT_HCIBTUSB_MTK=y \
-       CONFIG_BT_HCIBTUSB_RTL=n \
+       CONFIG_BT_HCIBTUSB_RTL=y \
        CONFIG_BT_HCIUART \
        CONFIG_BT_HCIUART_BCM=n \
        CONFIG_BT_HCIUART_INTEL=n \
@@ -56,7 +56,8 @@ define KernelPackage/bluetooth
        $(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
        $(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
        $(LINUX_DIR)/drivers/bluetooth/btusb.ko \
-       $(LINUX_DIR)/drivers/bluetooth/btintel.ko
+       $(LINUX_DIR)/drivers/bluetooth/btintel.ko \
+       $(LINUX_DIR)/drivers/bluetooth/btrtl.ko
   AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btusb)
 endef