kernel: bump 4.9 to 4.9.189
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 12 Aug 2019 08:10:44 +0000 (10:10 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Aug 2019 16:23:08 +0000 (18:23 +0200)
Refreshed all patches.

Compile-tested on: none
Runtime-tested on: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/021-bridge-multicast-to-unicast.patch
target/linux/generic/backport-4.9/024-3-tcp-tsq-add-shortcut-in-tcp_tasklet_func.patch
target/linux/generic/backport-4.9/024-5-tcp-tsq-add-a-shortcut-in-tcp_small_queue_check.patch
target/linux/generic/backport-4.9/024-6-tcp-tcp_mtu_probe-is-likely-to-exit-early.patch
target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
target/linux/generic/backport-4.9/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/pending-4.9/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch

index 97188d875bf4dbe5a6ffda806beef2706966982e..14aaac220bfc160e0ca060ba3535051fdd0bb83c 100644 (file)
@@ -6,11 +6,11 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.9 = .188
+LINUX_VERSION-4.9 = .189
 LINUX_VERSION-4.14 = .137
 LINUX_VERSION-4.19 = .65
 
-LINUX_KERNEL_HASH-4.9.188 = 27539853b25d1830fe81b108f39249c6ddf8b47257cdba09404ba0949863e222
+LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
 LINUX_KERNEL_HASH-4.14.137 = 93f8e91329300f325a5b4dd9de1f51c0b1bf9591dfd2274044c2f70f96bae228
 LINUX_KERNEL_HASH-4.19.65 = e59939186916c0286289c5bf78b83fac0d71a807241c6b1899bfe7a84486dedf
 
index 8fc5880041ca987efd7d0f5dabe2180202b23da5..42daacf50d0061be5acaa9de2a070087bc4c9c7c 100644 (file)
@@ -303,8 +303,8 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
 +                      if (!br_port_group_equal(p, port, src))
                                continue;
  
-                       rcu_assign_pointer(*pp, p->next);
-@@ -1517,7 +1555,7 @@ br_multicast_leave_group(struct net_brid
+                       if (p->flags & MDB_PG_FLAGS_PERMANENT)
+@@ -1520,7 +1558,7 @@ br_multicast_leave_group(struct net_brid
                for (p = mlock_dereference(mp->ports, br);
                     p != NULL;
                     p = mlock_dereference(p->next, br)) {
@@ -313,7 +313,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
                                continue;
  
                        if (!hlist_unhashed(&p->mglist) &&
-@@ -1568,7 +1606,8 @@ out:
+@@ -1571,7 +1609,8 @@ out:
  static void br_ip4_multicast_leave_group(struct net_bridge *br,
                                         struct net_bridge_port *port,
                                         __be32 group,
@@ -323,7 +323,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  {
        struct br_ip br_group;
        struct bridge_mcast_own_query *own_query;
-@@ -1583,14 +1622,15 @@ static void br_ip4_multicast_leave_group
+@@ -1586,14 +1625,15 @@ static void br_ip4_multicast_leave_group
        br_group.vid = vid;
  
        br_multicast_leave_group(br, port, &br_group, &br->ip4_other_query,
@@ -341,7 +341,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  {
        struct br_ip br_group;
        struct bridge_mcast_own_query *own_query;
-@@ -1605,7 +1645,7 @@ static void br_ip6_multicast_leave_group
+@@ -1608,7 +1648,7 @@ static void br_ip6_multicast_leave_group
        br_group.vid = vid;
  
        br_multicast_leave_group(br, port, &br_group, &br->ip6_other_query,
@@ -350,7 +350,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  }
  #endif
  
-@@ -1648,6 +1688,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1651,6 +1691,7 @@ static int br_multicast_ipv4_rcv(struct
                                 u16 vid)
  {
        struct sk_buff *skb_trimmed = NULL;
@@ -358,7 +358,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
        struct igmphdr *ih;
        int err;
  
-@@ -1663,13 +1704,14 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1666,13 +1707,14 @@ static int br_multicast_ipv4_rcv(struct
        }
  
        ih = igmp_hdr(skb);
@@ -374,7 +374,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb_trimmed, vid);
-@@ -1678,7 +1720,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1681,7 +1723,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb_trimmed, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
@@ -383,7 +383,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
                break;
        }
  
-@@ -1698,6 +1740,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1701,6 +1743,7 @@ static int br_multicast_ipv6_rcv(struct
                                 u16 vid)
  {
        struct sk_buff *skb_trimmed = NULL;
@@ -391,7 +391,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
        struct mld_msg *mld;
        int err;
  
-@@ -1717,8 +1760,10 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1720,8 +1763,10 @@ static int br_multicast_ipv6_rcv(struct
  
        switch (mld->mld_type) {
        case ICMPV6_MGM_REPORT:
@@ -403,7 +403,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
                break;
        case ICMPV6_MLD2_REPORT:
                err = br_ip6_multicast_mld2_report(br, port, skb_trimmed, vid);
-@@ -1727,7 +1772,8 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1730,7 +1775,8 @@ static int br_multicast_ipv6_rcv(struct
                err = br_ip6_multicast_query(br, port, skb_trimmed, vid);
                break;
        case ICMPV6_MGM_REDUCTION:
index 0d955a518c6cf43b23720331ef669ecef0edfd10..caa8cc9be230f57bbdf7a32df3de07acbac17166 100644 (file)
@@ -60,7 +60,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                nval = cmpxchg(&tp->tsq_flags, oval, nval);
                if (nval != oval)
                        continue;
-@@ -2226,6 +2226,8 @@ static bool tcp_write_xmit(struct sock *
+@@ -2235,6 +2235,8 @@ static bool tcp_write_xmit(struct sock *
                    unlikely(tso_fragment(sk, skb, limit, mss_now, gfp)))
                        break;
  
index 37b4f0ffd110d66107f2099520bee3e638ffb5a5..c577d4e72fe8975522ecf4f1c5fb5bc183459c5a 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -2131,6 +2131,15 @@ static bool tcp_small_queue_check(struct
+@@ -2140,6 +2140,15 @@ static bool tcp_small_queue_check(struct
        limit <<= factor;
  
        if (atomic_read(&sk->sk_wmem_alloc) > limit) {
index 88a5ef97044927ea1229b584fc8f13a0050290ef..f74556912e31344576f0b97e5260df6d6dde4bb1 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1964,26 +1964,26 @@ static bool tcp_can_coalesce_send_queue_
+@@ -1973,26 +1973,26 @@ static bool tcp_can_coalesce_send_queue_
   */
  static int tcp_mtu_probe(struct sock *sk)
  {
index b30b7cea9039ffebb2989183cc361a2534cd88ea..edb933b8c4ba1529aa2d0042c72e5a668369bdd0 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (nval != oval)
                        continue;
  
-@@ -2140,7 +2140,7 @@ static bool tcp_small_queue_check(struct
+@@ -2149,7 +2149,7 @@ static bool tcp_small_queue_check(struct
                    skb->prev == sk->sk_write_queue.next)
                        return false;
  
@@ -123,7 +123,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                /* It is possible TX completion already happened
                 * before we set TSQ_THROTTLED, so we must
                 * test again the condition.
-@@ -2238,8 +2238,8 @@ static bool tcp_write_xmit(struct sock *
+@@ -2247,8 +2247,8 @@ static bool tcp_write_xmit(struct sock *
                    unlikely(tso_fragment(sk, skb, limit, mss_now, gfp)))
                        break;
  
@@ -134,7 +134,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (tcp_small_queue_check(sk, skb, 0))
                        break;
  
-@@ -3550,8 +3550,6 @@ void __tcp_send_ack(struct sock *sk, u32
+@@ -3559,8 +3559,6 @@ void __tcp_send_ack(struct sock *sk, u32
        /* We do not want pure acks influencing TCP Small Queues or fq/pacing
         * too much.
         * SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
index e94140613eb54841a704f1e3d00c82bf094b88e9..15856d3a89bd1629cd75eea1810826157d635357 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1597,7 +1597,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1606,7 +1606,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2127,7 +2127,7 @@ static bool tcp_small_queue_check(struct
+@@ -2136,7 +2136,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index af9a5b191492db3da833fa3e79c6116e974542c9..9979c22fc3a868ec57344b5836061294fbce9274 100644 (file)
@@ -308,9 +308,9 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        int encap_limit = -1;
        __u16 offset;
        struct flowi6 fl6;
-@@ -1362,6 +1503,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
-                       fl6.flowi6_mark = skb->mark;
-       }
+@@ -1364,6 +1505,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+       dsfield = INET_ECN_encapsulate(dsfield, ipv6_get_dsfield(ipv6h));
  
 +      /* try to find matching FMR */
 +      for (fmr = t->parms.fmrs; fmr; fmr = fmr->next) {