tools/meson: update to 0.59.2
authorRosen Penev <rosenp@gmail.com>
Tue, 5 Oct 2021 01:48:30 +0000 (18:48 -0700)
committerPaul Spooren <mail@aparcar.org>
Fri, 8 Oct 2021 00:09:40 +0000 (14:09 -1000)
Update install procedure based on upstream feedback. Normally, meson is
to be installed with pip. But as pip is not mandated by the build
system, it cannot be used. Upstream provides a nice script to pack meson
automatically.

Moved src/ to files/. No need to copy to BUILD_DIR.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/meson.mk
tools/meson/Makefile
tools/meson/files/openwrt-cross.txt.in [new file with mode: 0644]
tools/meson/files/openwrt-native.txt.in [new file with mode: 0644]
tools/meson/src/openwrt-cross.txt.in [deleted file]
tools/meson/src/openwrt-native.txt.in [deleted file]

index 01d0ce02807ede838a3a997213c4022fdfaa00fc..9862f0e662b74b5b88440c7aa061363e5848b2f4 100644 (file)
@@ -19,7 +19,6 @@
 #
 # Host packages are built in the same fashion, just use these vars instead:
 #
-# HOST_BUILD_DEPENDS:=meson/host
 # MESON_HOST_ARGS+=-Dfoo -Dbar=baz
 # MESON_HOST_VARS+=FOO=bar
 
@@ -57,7 +56,7 @@ MESON_CPU:="$(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))"
 endif
 
 define Meson
-       $(2) $(STAGING_DIR_HOST)/bin/$(PYTHON) $(MESON_DIR)/meson.py $(1)
+       $(2) $(STAGING_DIR_HOST)/bin/meson $(1)
 endef
 
 define Meson/CreateNativeFile
index bae89654a5067dd85993b9b86a8bb7ed445316de..0cf0efba4726689726c69085be569e70b9163b30 100644 (file)
@@ -1,11 +1,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meson
-PKG_VERSION:=0.59.1
+PKG_VERSION:=0.59.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=db586a451650d46bbe10984a87b79d9bcdc1caebf38d8e189f8848f8d502356d
+PKG_HASH:=13dee549a7ba758b7e33ce7719f28d1d337a98d10d378a4779ccc996f5a2fc49
 
 PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
 PKG_LICENSE:=Apache-2.0
@@ -20,8 +20,11 @@ define Host/Compile
 endef
 
 define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+       $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --interpreter $(STAGING_DIR_HOST)/bin/$(PYTHON) --outfile $(STAGING_DIR_HOST)/bin/meson
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/lib/meson
-       $(CP) $(HOST_BUILD_DIR)/* $(STAGING_DIR_HOST)/lib/meson/
+       $(INSTALL_CONF) files/openwrt-cross.txt.in $(STAGING_DIR_HOST)/lib/meson/
+       $(INSTALL_CONF) files/openwrt-native.txt.in $(STAGING_DIR_HOST)/lib/meson/
 endef
 
 define Host/Clean
diff --git a/tools/meson/files/openwrt-cross.txt.in b/tools/meson/files/openwrt-cross.txt.in
new file mode 100644 (file)
index 0000000..30b4c11
--- /dev/null
@@ -0,0 +1,23 @@
+[binaries]
+c = [@CC@]
+cpp = [@CXX@]
+ar = '@AR@'
+strip = '@STRIP@'
+nm = '@NM@'
+pkgconfig = '@PKGCONFIG@'
+
+[built-in options]
+c_args = [@CFLAGS@]
+c_link_args = [@LDFLAGS@]
+cpp_args = [@CXXFLAGS@]
+cpp_link_args = [@LDFLAGS@]
+prefix = '/usr'
+
+[host_machine]
+system = 'linux'
+cpu_family = '@ARCH@'
+cpu = '@CPU@'
+endian = '@ENDIAN@'
+
+[properties]
+needs_exe_wrapper = true
diff --git a/tools/meson/files/openwrt-native.txt.in b/tools/meson/files/openwrt-native.txt.in
new file mode 100644 (file)
index 0000000..50308ec
--- /dev/null
@@ -0,0 +1,13 @@
+[binaries]
+c = [@CC@]
+cpp = [@CXX@]
+pkgconfig = '@PKGCONFIG@'
+
+[built-in options]
+c_args = [@CFLAGS@]
+c_link_args = [@LDFLAGS@]
+cpp_args = [@CXXFLAGS@]
+cpp_link_args = [@LDFLAGS@]
+prefix = '@PREFIX@'
+sbindir = 'bin'
+libdir = 'lib'
diff --git a/tools/meson/src/openwrt-cross.txt.in b/tools/meson/src/openwrt-cross.txt.in
deleted file mode 100644 (file)
index 30b4c11..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-[binaries]
-c = [@CC@]
-cpp = [@CXX@]
-ar = '@AR@'
-strip = '@STRIP@'
-nm = '@NM@'
-pkgconfig = '@PKGCONFIG@'
-
-[built-in options]
-c_args = [@CFLAGS@]
-c_link_args = [@LDFLAGS@]
-cpp_args = [@CXXFLAGS@]
-cpp_link_args = [@LDFLAGS@]
-prefix = '/usr'
-
-[host_machine]
-system = 'linux'
-cpu_family = '@ARCH@'
-cpu = '@CPU@'
-endian = '@ENDIAN@'
-
-[properties]
-needs_exe_wrapper = true
diff --git a/tools/meson/src/openwrt-native.txt.in b/tools/meson/src/openwrt-native.txt.in
deleted file mode 100644 (file)
index 50308ec..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-[binaries]
-c = [@CC@]
-cpp = [@CXX@]
-pkgconfig = '@PKGCONFIG@'
-
-[built-in options]
-c_args = [@CFLAGS@]
-c_link_args = [@LDFLAGS@]
-cpp_args = [@CXXFLAGS@]
-cpp_link_args = [@LDFLAGS@]
-prefix = '@PREFIX@'
-sbindir = 'bin'
-libdir = 'lib'