add support for Hauppauge Broadway
authorJohn Crispin <john@openwrt.org>
Mon, 10 Dec 2012 14:13:01 +0000 (14:13 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 10 Dec 2012 14:13:01 +0000 (14:13 +0000)
This patch introduces OpenWRT support for the base Hauppauge/PCTV Broadway
platform.  It doesn't deal with the TV tuner or transcoder at this point,
but the core functionality is working (Ethernet, wireless, USB, buttons,
LEDs, etc).

Signed-off-by: Devin Heitmueller <dheitmueller@kernellabs.com>
SVN-Revision: 34595

14 files changed:
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/leds
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-broadway.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.3
target/linux/ramips/rt305x/config-3.6
target/linux/ramips/rt305x/profiles/broadway.mk [new file with mode: 0644]

index d02b1e0b441fc3a74ca7f55fd20a109a3ba29aac..32c97fce41421df9ab9a515d1ce4d7f0f32e2f53 100644 (file)
@@ -59,6 +59,7 @@ case "$FIRMWARE" in
        all5002 | \
        argus-atp52b | \
        bc2 | \
+       broadway | \
        carambola | \
        dir-615-h1 | \
        dir-620-a1 | \
index 81d9c44ea83faf2192eea09be999ca26529e55b3..e444db7ceb5028c5ec31b5411ccdea07b3cb279e 100755 (executable)
@@ -28,6 +28,10 @@ case $board in
        bc2)
                set_usb_led "bc2:blue:usb"
                ;;
+       broadway)
+               set_usb_led "red:diskmounted"
+               set_wifi_led "red:wps_active"
+               ;;
        dir-300-b1|\
        dir-600-b1|\
        dir-600-b2|\
index dff0fd66f8aacac85971f6b922409bde829ae97c..5d49923bb5225515bed50f12f31c4646ecff1d27 100755 (executable)
@@ -43,7 +43,8 @@ ramips_setup_interfaces()
 
        case $board in
        all0256n | \
-       all5002)
+       all5002 | \
+       broadway)
                ucidef_set_interface_lan "eth0"
                ;;
 
@@ -141,6 +142,7 @@ ramips_setup_macs()
        3g-6200n | \
        argus-atp52b | \
        bc2 | \
+       broadway | \
        f5d8235-v1 | \
        nw718 | \
        psr-680w | \
index 379f74dd54542b966d79001dee807aeca613fe4b..b04ec7744cef6133d7f9c258c4b01fee1d2f75ef 100644 (file)
@@ -13,6 +13,7 @@ preinit_set_mac_address() {
                ifconfig eth0 hw ether $mac 2>/dev/null
                ;;
        bc2 |\
+       broadway |\
        dir-620-a1 |\
        esr-9753 |\
        freestation5 |\
index abefdc52049161c96da52aec5295cbe5bbaf47fc..2d8a7e65d2065c3c12cfd301c258f172588808cc 100755 (executable)
@@ -110,6 +110,9 @@ ramips_board_name() {
        *"F5D8235 v2")
                name="f5d8235-v2"
                ;;
+       *"Hauppauge Broadway")
+               name="broadway"
+               ;;
        *"La Fonera 2.0N")
                name="fonera20n"
                ;;
index 1acbbffa4fd296c2a83d9e2ad0da8f86f63a4e0f..2ec4749f9f9979bc416ed0789ddc6762f73c0a59 100755 (executable)
@@ -19,6 +19,7 @@ platform_check_image() {
        all0256n | \
        all5002 | \
        bc2 | \
+       broadway | \
        carambola | \
        dir-300-b1 | \
        dir-600-b1 | \
index d71bd1c023c5d853e22419dc7a4a7330412a1fd0..f8dbcbc25cd0618e204a01138bc9450299e51ba5 100644 (file)
@@ -39,6 +39,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_ALL0239_3G,         /* ALL0239-3G */
        RAMIPS_MACH_ARGUS_ATP52B,       /* Argus ATP-52B */
        RAMIPS_MACH_BC2,                /* NexAira BC2 */
+       RAMIPS_MACH_BROADWAY,           /* Hauppauge Broadway */
        RAMIPS_MACH_DAP_1350,           /* D-Link DAP-1350 */
        RAMIPS_MACH_ESR_9753,           /* Senao / EnGenius ESR-9753*/
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
index 562bea6af10b7fbe4be79204a310834972ff485a..769603dc81e6be39791a8af644daaa9fb5924cab 100644 (file)
@@ -91,6 +91,11 @@ config RT305X_MACH_ESR_9753
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_BROADWAY
+       bool "Hauppauge Broadway support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_FONERA20N
        bool "La Fonera20N board support"
        select RALINK_DEV_GPIO_BUTTONS
index 2cf25a1528d48cb383ae9702a3f0419120086037..c61fba88cd83146d665e6e9617093923cfe5d45a 100644 (file)
@@ -16,6 +16,7 @@ obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B)        += mach-argus-atp52b.o
 obj-$(CONFIG_RT305X_MACH_BC2)          += mach-bc2.o
 obj-$(CONFIG_RT305X_MACH_ALL0256N)     += mach-all0256n.o
 obj-$(CONFIG_RT305X_MACH_ALL5002)      += mach-all5002.o
+obj-$(CONFIG_RT305X_MACH_BROADWAY)     += mach-broadway.o
 obj-$(CONFIG_RT305X_MACH_CARAMBOLA)    += mach-carambola.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_DIR_615_H1)   += mach-dir-615-h1.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-broadway.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-broadway.c
new file mode 100644 (file)
index 0000000..74dfaa3
--- /dev/null
@@ -0,0 +1,87 @@
+/*
+ *  Hauppauge/PCTV Broadway Support
+ *
+ *  Copyright (C) 2012 Devin Heitmueller <dheitmueller@kernellabs.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define BROADWAY_GPIO_LED_DISKMOUNT    9
+#define BROADWAY_GPIO_LED_WPS          14
+
+#define BROADWAY_GPIO_BUTTON_WPS               0
+#define BROADWAY_GPIO_BUTTON_FACTORYRESET      13
+
+#define BROADWAY_KEYS_POLL_INTERVAL    20
+#define BROADWAY_KEYS_DEBOUNCE_INTERVAL        (3 * BROADWAY_KEYS_POLL_INTERVAL)
+
+static struct gpio_led broadway_leds_gpio[] __initdata = {
+       {
+               .name           = "red:diskmounted",
+               .gpio           = BROADWAY_GPIO_LED_DISKMOUNT,
+               .active_low     = 1,
+       },
+       {
+               .name           = "red:wps_active",
+               .gpio           = BROADWAY_GPIO_LED_WPS,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button broadway_gpio_buttons[] __initdata = {
+       {
+               .desc           = "Factory Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = BROADWAY_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BROADWAY_GPIO_BUTTON_FACTORYRESET,
+               .active_low     = 1,
+       },
+#ifdef DJH_WPS_BUTTON_NOT_WIRED_TO_GPIO
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = BROADWAY_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BROADWAY_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       },
+#endif
+};
+
+static void __init broadway_init(void)
+{
+       rt305x_gpio_init((RT305X_GPIO_MODE_GPIO <<
+                         RT305X_GPIO_MODE_UART0_SHIFT));
+
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(broadway_leds_gpio),
+                                 broadway_leds_gpio);
+       ramips_register_gpio_buttons(-1, BROADWAY_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(broadway_gpio_buttons),
+                                    broadway_gpio_buttons);
+
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_BROADWAY, "BROADWAY", "Hauppauge Broadway",
+             broadway_init);
index 585eeac3fe17ab870385434b9011845c8c4009c2..e7f78c9dfc5de87646346a9d59a3dd4d4ae242e0 100644 (file)
@@ -162,6 +162,22 @@ define BuildFirmware/ARGUS_ATP52B
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_argus_atp52b)),$(mtd_argus_atp52b_kernel_part_size),$(mtd_argus_atp52b_rootfs_part_size))
 endef
 
+# djh - Note all of these are marked Read-Only for now
+mtdlayout_broadway=192k(bootloader)ro,64k(config)ro,64k(factory)ro,1024k(kernel)ro,6720k(rootfs),7744k@0x50000(firmware)
+mtd_broadway_kernel_part_size=1048576
+mtd_broadway_rootfs_part_size=6881280
+define BuildFirmware/BROADWAY
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_broadway)),$(mtd_broadway_kernel_part_size),$(mtd_broadway_rootfs_part_size))
+       mkimage -A mips -O linux -T kernel -C lzma $(call kernel_entry)\
+        -n 'Broadway Kernel Image' \
+        -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage
+       $(call CatFiles,$(KDIR)/vmlinux-$(2).uImage,$(mtd_broadway_kernel_part_size),$(KDIR)/root.$(1),$(mtd_broadway_rootfs_part_size),$(call imgname,$(1),$(2))-factory.bin)
+endef
+
+define BuildFirmware/BROADWAY/initramfs
+       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_broadway)))
+endef
+
 define BuildFirmware/Buffalo
        $(call MkImageLzma,$(2),$(3))
        $(call Sysupgrade/KRuImage,$(1),$(2),$(4),$(5))
@@ -461,6 +477,10 @@ define Image/Build/Profile/BC2
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,bc2,BC2,ttyS1,57600,phys)
 endef
 
+define Image/Build/Profile/BROADWAY
+       $(call Image/Build/Template/$(fs_squash)/$(1),BROADWAY,broadway,BROADWAY,ttyS1,57600,phys)
+endef
+
 define Image/Build/Profile/CARAMBOLA
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,carambola,CARAMBOLA,ttyS1,115200,phys)
 endef
@@ -604,6 +624,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ALL5002,$(1))
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
+       $(call Image/Build/Profile/BROADWAY,$(1))
        $(call Image/Build/Profile/CARAMBOLA,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/DIR615H1,$(1))
index 7b6bafdf1b318e7b29cb703c6f39fc5689ec5ac4..8105b0fa6f2fb0ae527bc68170e45e7112307b83 100644 (file)
@@ -91,6 +91,7 @@ CONFIG_RT305X_MACH_ALL0256N=y
 CONFIG_RT305X_MACH_ALL5002=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y
 CONFIG_RT305X_MACH_BC2=y
+CONFIG_RT305X_MACH_BROADWAY=y
 CONFIG_RT305X_MACH_CARAMBOLA=y
 CONFIG_RT305X_MACH_DAP_1350=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
index 86361af9e78d5ff6d47581b38e5452d049c67ce7..1971c2ac30cf4f0c3427968d3d53b881faabac65 100644 (file)
@@ -43,6 +43,7 @@ CONFIG_HAS_IOMEM=y
 CONFIG_HAS_IOPORT=y
 CONFIG_HAVE_ARCH_JUMP_LABEL=y
 CONFIG_HAVE_ARCH_KGDB=y
+CONFIG_HAVE_CLK=y
 CONFIG_HAVE_C_RECORDMCOUNT=y
 CONFIG_HAVE_DMA_API_DEBUG=y
 CONFIG_HAVE_DMA_ATTRS=y
@@ -96,6 +97,7 @@ CONFIG_RT305X_MACH_ALL0256N=y
 CONFIG_RT305X_MACH_ALL5002=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y
 CONFIG_RT305X_MACH_BC2=y
+CONFIG_RT305X_MACH_BROADWAY=y
 CONFIG_RT305X_MACH_CARAMBOLA=y
 CONFIG_RT305X_MACH_DAP_1350=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
diff --git a/target/linux/ramips/rt305x/profiles/broadway.mk b/target/linux/ramips/rt305x/profiles/broadway.mk
new file mode 100644 (file)
index 0000000..8e994bd
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BROADWAY
+       NAME:=Hauppauge Broadway
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-rt305x-dwc_otg \
+               kmod-ledtrig-usbdev restorefactory
+endef
+
+define Profile/BROADWAY/Description
+       Package set for Hauppauge Broadway
+endef
+
+$(eval $(call Profile,BROADWAY))