ipq806x: increase kernel partition size for the Netgear Nighthawk X4 R7500v2
authorStefan Lippers-Hollmann <s.l-h@gmx.de>
Fri, 18 May 2018 02:18:17 +0000 (04:18 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 May 2018 18:34:14 +0000 (20:34 +0200)
Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the
2 MB reserved for the kernel partition by the OEM firmware anymore.

This patch increases the kernel partition from 2 MB to 4 MB, at the
expense of the rootfs, for all supported kernels.

WARNING: This breaks sysupgrade! Flashing a firmware containing this
changed partitioning from an older image with 2 MB reserved for the
kernel partion requires the tftp recovery procedure, thereby losing
all settings.

This change follows the functional example of the Netgear r7800, but
has not been runtime tested on a Netgear Nighthawk X4 R7500v2.

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
target/linux/ipq806x/files-4.14/arch/arm/boot/dts/qcom-ipq8064-r7500v2.dts
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq8064-r7500v2.dts
target/linux/ipq806x/image/Makefile

index c4b0c4b5a7f7dfc8cf01b85b3e0e3388ad2c69bf..da0ac5b68ec2fd4959bff076939497b376b2f33f 100644 (file)
 
                                        kernel@1480000 {
                                                label = "kernel";
 
                                        kernel@1480000 {
                                                label = "kernel";
-                                               reg = <0x1480000 0x0200000>;
+                                               reg = <0x1480000 0x0400000>;
                                        };
 
                                        };
 
-                                       ubi@1680000 {
+                                       ubi@1880000 {
                                                label = "ubi";
                                                label = "ubi";
-                                               reg = <0x1680000 0x1E00000>;
+                                               reg = <0x1880000 0x1C00000>;
                                        };
 
                                        netgear@3480000 {
                                        };
 
                                        netgear@3480000 {
index c4b0c4b5a7f7dfc8cf01b85b3e0e3388ad2c69bf..da0ac5b68ec2fd4959bff076939497b376b2f33f 100644 (file)
 
                                        kernel@1480000 {
                                                label = "kernel";
 
                                        kernel@1480000 {
                                                label = "kernel";
-                                               reg = <0x1480000 0x0200000>;
+                                               reg = <0x1480000 0x0400000>;
                                        };
 
                                        };
 
-                                       ubi@1680000 {
+                                       ubi@1880000 {
                                                label = "ubi";
                                                label = "ubi";
-                                               reg = <0x1680000 0x1E00000>;
+                                               reg = <0x1880000 0x1C00000>;
                                        };
 
                                        netgear@3480000 {
                                        };
 
                                        netgear@3480000 {
index 5a1faa3eadbb7d92450d75b4c247bd697ed8b65a..68b039b3aecc607a2b41e2556edadeb2a69994d5 100644 (file)
@@ -134,7 +134,7 @@ TARGET_DEVICES += netgear_r7500
 define Device/netgear_r7500v2
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500v2
 define Device/netgear_r7500v2
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500v2
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := R7500v2
        NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
        BLOCKSIZE := 128k
        NETGEAR_BOARD_ID := R7500v2
        NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
        BLOCKSIZE := 128k