add openbsd compatibility patch (thanks, wbx)
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 Dec 2006 20:58:51 +0000 (20:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 Dec 2006 20:58:51 +0000 (20:58 +0000)
SVN-Revision: 5749

scripts/config/lxdialog/Makefile
scripts/config/lxdialog/check-lxdialog.sh

index a82b2bac993a77faff6edf1bb120916972af5523..aed08e0170e987e00ce73c655fa92a0634a28f9f 100644 (file)
@@ -7,7 +7,14 @@ all: lxdialog
 # we really need to do so. (Do not call gcc as part of make mrproper)
 CFLAGS := $(shell sh check-lxdialog.sh -ccflags)
 LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
 # we really need to do so. (Do not call gcc as part of make mrproper)
 CFLAGS := $(shell sh check-lxdialog.sh -ccflags)
 LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
+
+# workaround for OpenBSD, which does not use symlinks to libncurses.so
+OS := $(shell uname -s)
+ifeq ($(strip $(OS)),OpenBSD)
+LIBS := -lncurses
+endif
+
+
 always         := $(hostprogs-y) dochecklxdialog
 
 %.o: %.c
 always         := $(hostprogs-y) dochecklxdialog
 
 %.o: %.c
index 50c5ff358b8296e13edb58cde88caf148ae68350..9a6c915e5a09ed56d0984a9a12f31ca1371fce1a 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/usr/bin/env bash
 # Check ncurses compatibility
 
 # What library to link
 # Check ncurses compatibility
 
 # What library to link