octeon: Add and set CPU type Octeon+ as default
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Tue, 19 Jun 2018 06:44:54 +0000 (08:44 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 20 Jun 2018 13:36:02 +0000 (15:36 +0200)
The lowest CPU type used by supported Octeon platform
is Octeon+ (EdgeRouter Lite) while EdgeRouter Pro/ER-8 uses
Octeon II which is backwards compatible with Octeon+.

Sources:
https://community.ubnt.com/t5/EdgeRouter/EdgeRouter-Pro-CPU/td-p/654599
https://www.cavium.com/octeon-II-CN68XX.html
"OCTEON II family is fully software compatible with the widely-adopted
OCTEON Plus family"

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
include/target.mk
target/linux/octeon/Makefile

index a97cda2c3ac1c624b1b759def59cdbded1a4d597..6afbd7583965d5d1e66ef8ad9e60603256236851 100644 (file)
@@ -176,6 +176,7 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_24kc = -mips32r2 -mtune=24kc
     CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc
     CPU_CFLAGS_octeon = -march=octeon -mabi=64
+    CPU_CFLAGS_octeonplus = -march=octeon+ -mabi=64
   endif
   ifeq ($(ARCH),i386)
     CPU_TYPE ?= pentium
index bbf1296c21e9134f1582f685ccdad5014c9f08c0..6c0623cb9bfac4d1169c7fb8cbdae6e47ae40ba6 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs ramdisk pci usb
-CPU_TYPE:=octeon
+CPU_TYPE:=octeonplus
 MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.14