toolchain/gcc: fix --with-isl path
authorSyrone Wong <wong.syrone@gmail.com>
Tue, 30 May 2017 07:10:02 +0000 (15:10 +0800)
committerFelix Fietkau <nbd@nbd.name>
Tue, 30 May 2017 07:32:10 +0000 (09:32 +0200)
This fixes GCC 7 compilation when GRAPHITE is selected.
The path is replaced with $(TOOLCHAIN_DIR), while it should be
$(STAGING_DIR_HOST). To keep in sync with the path of gmp,
mpfr and mpc, I'm using $(TOPDIR)/staging_dir/host.

Fixes: f62f4b3c5c9d ("build: stop overriding STAGING_DIR_HOST for toolchain build")
Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
toolchain/gcc/common.mk

index 55ae1a2c09b3fcbf777335929ce62f4bc46ab72d..b28d3ce36befa4f5acf6db131c85478f63312381 100644 (file)
@@ -91,9 +91,9 @@ ifdef CONFIG_INSTALL_GCCGO
 endif
 
 ifdef CONFIG_GCC_USE_GRAPHITE
-  GRAPHITE_CONFIGURE=--with-isl=$(HOST_BUILD_PREFIX)
+  GRAPHITE_CONFIGURE:= --with-isl=$(TOPDIR)/staging_dir/host
 else
-  GRAPHITE_CONFIGURE=--without-isl --without-cloog
+  GRAPHITE_CONFIGURE:= --without-isl --without-cloog
 endif
 
 GCC_CONFIGURE:= \