bcm53xx: update kernel 5.4 DTS to upstream 5.9 state
authorRafał Miłecki <rafal@milecki.pl>
Tue, 4 Aug 2020 08:31:11 +0000 (10:31 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 4 Aug 2020 11:27:19 +0000 (13:27 +0200)
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-5.4/031-v5.8-ARM-dts-BCM5301X-Add-missing-memory-device_type-for-.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-5.4/032-v5.9-ARM-dts-BCM5301X-Specify-switch-ports-for-Luxul-devi.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-5.4/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch [deleted file]

diff --git a/target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch b/target/linux/bcm53xx/patches-5.4/030-v5.5-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
new file mode 100644 (file)
index 0000000..67e85da
--- /dev/null
@@ -0,0 +1,82 @@
+From 984829e2d39b5ba9f817198d701c85511ef40528 Mon Sep 17 00:00:00 2001
+From: Dan Haab <dan.haab@legrand.com>
+Date: Wed, 2 Oct 2019 09:57:26 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XWC-2000
+
+It's a simple network device based on BCM47094 with just a single
+Ethernet port.
+
+Signed-off-by: Dan Haab <dan.haab@legrand.com>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile                    |  1 +
+ arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 53 +++++++++++++++++++
+ 2 files changed, 54 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -113,6 +113,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm47094-luxul-abr-4500.dtb \
+       bcm47094-luxul-xap-1610.dtb \
+       bcm47094-luxul-xbr-4500.dtb \
++      bcm47094-luxul-xwc-2000.dtb \
+       bcm47094-luxul-xwr-3100.dtb \
+       bcm47094-luxul-xwr-3150-v1.dtb \
+       bcm47094-netgear-r8500.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+@@ -0,0 +1,53 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright 2019 Legrand AV Inc.
++ */
++
++/dts-v1/;
++
++#include "bcm47094.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++      compatible = "luxul,xwc-2000-v1", "brcm,bcm47094", "brcm,bcm4708";
++      model = "Luxul XWC-2000 V1";
++
++      chosen {
++              bootargs = "earlycon";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000
++                     0x88000000 0x18000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              status  {
++                      label = "bcm53xx:green:status";
++                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "timer";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 19 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&uart1 {
++      status = "okay";
++};
++
++&spi_nor {
++      status = "okay";
++};
diff --git a/target/linux/bcm53xx/patches-5.4/031-v5.8-ARM-dts-BCM5301X-Add-missing-memory-device_type-for-.patch b/target/linux/bcm53xx/patches-5.4/031-v5.8-ARM-dts-BCM5301X-Add-missing-memory-device_type-for-.patch
new file mode 100644 (file)
index 0000000..43a719a
--- /dev/null
@@ -0,0 +1,30 @@
+From de1f6d9304c38e414552c3565d36286609ced0c1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
+Date: Mon, 8 Jun 2020 18:33:41 +0200
+Subject: [PATCH] ARM: dts: BCM5301X: Add missing memory "device_type" for
+ Luxul XWC-2000
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This property is needed since commit abe60a3a7afb ("ARM: dts: Kill off
+skeleton{64}.dtsi"). Without it booting silently hangs at:
+[    0.000000] Memory policy: Data cache writealloc
+
+Fixes: 984829e2d39b ("ARM: dts: BCM5301X: Add DT for Luxul XWC-2000")
+Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+@@ -17,6 +17,7 @@
+       };
+       memory {
++              device_type = "memory";
+               reg = <0x00000000 0x08000000
+                      0x88000000 0x18000000>;
+       };
diff --git a/target/linux/bcm53xx/patches-5.4/032-v5.9-ARM-dts-BCM5301X-Specify-switch-ports-for-Luxul-devi.patch b/target/linux/bcm53xx/patches-5.4/032-v5.9-ARM-dts-BCM5301X-Specify-switch-ports-for-Luxul-devi.patch
new file mode 100644 (file)
index 0000000..a2f05d3
--- /dev/null
@@ -0,0 +1,301 @@
+From 99e5a32902d9e144568add5dd8791aa66a69f0bf Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
+Date: Mon, 8 Jun 2020 11:37:33 +0200
+Subject: [PATCH] ARM: dts: BCM5301X: Specify switch ports for Luxul devices
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+All those devices use standard BCM53011 (rev 5) or BCM53012 (rev 0).
+
+Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/bcm4708-luxul-xap-1510.dts  | 25 ++++++++++++
+ arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts  | 20 ++++++++++
+ arch/arm/boot/dts/bcm47081-luxul-xap-1410.dts | 20 ++++++++++
+ arch/arm/boot/dts/bcm47081-luxul-xwr-1200.dts | 40 +++++++++++++++++++
+ arch/arm/boot/dts/bcm47094-luxul-xap-1610.dts | 25 ++++++++++++
+ arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 20 ++++++++++
+ arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts | 40 +++++++++++++++++++
+ .../boot/dts/bcm47094-luxul-xwr-3150-v1.dts   | 40 +++++++++++++++++++
+ 8 files changed, 230 insertions(+)
+
+--- a/arch/arm/boot/dts/bcm4708-luxul-xap-1510.dts
++++ b/arch/arm/boot/dts/bcm4708-luxul-xap-1510.dts
+@@ -60,3 +60,28 @@
+ &usb3_phy {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@0 {
++                      reg = <0>;
++                      label = "poe";
++              };
++
++              port@4 {
++                      reg = <4>;
++                      label = "lan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
++++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
+@@ -67,3 +67,23 @@
+ &usb3_phy {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@4 {
++                      reg = <4>;
++                      label = "lan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm47081-luxul-xap-1410.dts
++++ b/arch/arm/boot/dts/bcm47081-luxul-xap-1410.dts
+@@ -60,3 +60,23 @@
+ &usb3_phy {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@4 {
++                      reg = <4>;
++                      label = "poe";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm47081-luxul-xwr-1200.dts
++++ b/arch/arm/boot/dts/bcm47081-luxul-xwr-1200.dts
+@@ -108,3 +108,43 @@
+ &usb3_phy {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@0 {
++                      reg = <0>;
++                      label = "lan4";
++              };
++
++              port@1 {
++                      reg = <1>;
++                      label = "lan3";
++              };
++
++              port@2 {
++                      reg = <2>;
++                      label = "lan2";
++              };
++
++              port@3 {
++                      reg = <3>;
++                      label = "lan1";
++              };
++
++              port@4 {
++                      reg = <4>;
++                      label = "wan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm47094-luxul-xap-1610.dts
++++ b/arch/arm/boot/dts/bcm47094-luxul-xap-1610.dts
+@@ -54,3 +54,28 @@
+ &spi_nor {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@0 {
++                      reg = <0>;
++                      label = "poe";
++              };
++
++              port@1 {
++                      reg = <1>;
++                      label = "lan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
+@@ -52,3 +52,23 @@
+ &spi_nor {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@0 {
++                      reg = <0>;
++                      label = "lan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts
+@@ -103,3 +103,43 @@
+ &usb3_phy {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@0 {
++                      reg = <0>;
++                      label = "lan4";
++              };
++
++              port@1 {
++                      reg = <1>;
++                      label = "lan3";
++              };
++
++              port@2 {
++                      reg = <2>;
++                      label = "lan2";
++              };
++
++              port@3 {
++                      reg = <3>;
++                      label = "lan1";
++              };
++
++              port@4 {
++                      reg = <4>;
++                      label = "wan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/bcm47094-luxul-xwr-3150-v1.dts
++++ b/arch/arm/boot/dts/bcm47094-luxul-xwr-3150-v1.dts
+@@ -74,3 +74,43 @@
+ &spi_nor {
+       status = "okay";
+ };
++
++&srab {
++      status = "okay";
++
++      ports {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              port@0 {
++                      reg = <0>;
++                      label = "lan4";
++              };
++
++              port@1 {
++                      reg = <1>;
++                      label = "lan3";
++              };
++
++              port@2 {
++                      reg = <2>;
++                      label = "lan2";
++              };
++
++              port@3 {
++                      reg = <3>;
++                      label = "lan1";
++              };
++
++              port@4 {
++                      reg = <4>;
++                      label = "wan";
++              };
++
++              port@5 {
++                      reg = <5>;
++                      label = "cpu";
++                      ethernet = <&gmac0>;
++              };
++      };
++};
diff --git a/target/linux/bcm53xx/patches-5.4/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch b/target/linux/bcm53xx/patches-5.4/130-ARM-dts-BCM5301X-Add-DT-for-Luxul-XWC-2000.patch
deleted file mode 100644 (file)
index 639bbb8..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-From: Dan Haab <dan.haab@legrand.com>
-Date: Wed, 2 Oct 2019 09:57:26 -0600
-Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul XWC-2000
-
-It's a simple network device based on BCM47094 with just a single
-Ethernet port.
-
-Signed-off-by: Dan Haab <dan.haab@legrand.com>
----
- arch/arm/boot/dts/Makefile                    |  1 +
- arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts | 53 +++++++++++++++++++
- 2 files changed, 54 insertions(+)
- create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -113,6 +113,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
-       bcm47094-luxul-abr-4500.dtb \
-       bcm47094-luxul-xap-1610.dtb \
-       bcm47094-luxul-xbr-4500.dtb \
-+      bcm47094-luxul-xwc-2000.dtb \
-       bcm47094-luxul-xwr-3100.dtb \
-       bcm47094-luxul-xwr-3150-v1.dtb \
-       bcm47094-netgear-r8500.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm47094-luxul-xwc-2000.dts
-@@ -0,0 +1,53 @@
-+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-+/*
-+ * Copyright 2019 Legrand AV Inc.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm47094.dtsi"
-+#include "bcm5301x-nand-cs0-bch8.dtsi"
-+
-+/ {
-+      compatible = "luxul,xwc-2000-v1", "brcm,bcm47094", "brcm,bcm4708";
-+      model = "Luxul XWC-2000 V1";
-+
-+      chosen {
-+              bootargs = "earlycon";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x08000000
-+                     0x88000000 0x18000000>;
-+      };
-+
-+      leds {
-+              compatible = "gpio-leds";
-+
-+              status  {
-+                      label = "bcm53xx:green:status";
-+                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "timer";
-+              };
-+      };
-+
-+      gpio-keys {
-+              compatible = "gpio-keys";
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+
-+              restart {
-+                      label = "Reset";
-+                      linux,code = <KEY_RESTART>;
-+                      gpios = <&chipcommon 19 GPIO_ACTIVE_LOW>;
-+              };
-+      };
-+};
-+
-+&uart1 {
-+      status = "okay";
-+};
-+
-+&spi_nor {
-+      status = "okay";
-+};