package.mk: replicate SSP and relro in both CFLAGS and LDFLAGS
authorSteven Barth <cyrus@openwrt.org>
Thu, 18 Jun 2015 10:48:28 +0000 (10:48 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 18 Jun 2015 10:48:28 +0000 (10:48 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46035

include/package.mk

index c69d92819779dd0ee92381620accd73ef2b80de6..7ba7401d44a01a7f31132d3763c7be5faab9f895 100644 (file)
@@ -48,11 +48,13 @@ endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_REGULAR
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_REGULAR)),1)
     TARGET_CFLAGS += -fstack-protector
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_REGULAR
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_REGULAR)),1)
     TARGET_CFLAGS += -fstack-protector
+    TARGET_LDFLAGS += -fstack-protector
   endif
 endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_STRONG
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_STRONG)),1)
     TARGET_CFLAGS += -fstack-protector-strong
   endif
 endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_STRONG
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_STRONG)),1)
     TARGET_CFLAGS += -fstack-protector-strong
+    TARGET_LDFLAGS += -fstack-protector-strong
   endif
 endif
 ifdef CONFIG_PKG_FORTIFY_SOURCE_1
   endif
 endif
 ifdef CONFIG_PKG_FORTIFY_SOURCE_1
@@ -68,11 +70,13 @@ endif
 ifdef CONFIG_PKG_RELRO_PARTIAL
   ifeq ($(strip $(PKG_RELRO_PARTIAL)),1)
     TARGET_CFLAGS += -Wl,-z,relro
 ifdef CONFIG_PKG_RELRO_PARTIAL
   ifeq ($(strip $(PKG_RELRO_PARTIAL)),1)
     TARGET_CFLAGS += -Wl,-z,relro
+    TARGET_LDFLAGS += -Wl,-z,relro
   endif
 endif
 ifdef CONFIG_PKG_RELRO_FULL
   ifeq ($(strip $(PKG_RELRO_FULL)),1)
     TARGET_CFLAGS += -Wl,-z,now -Wl,-z,relro
   endif
 endif
 ifdef CONFIG_PKG_RELRO_FULL
   ifeq ($(strip $(PKG_RELRO_FULL)),1)
     TARGET_CFLAGS += -Wl,-z,now -Wl,-z,relro
+    TARGET_LDFLAGS += -Wl,-z,now -Wl,-z,relro
   endif
 endif
 
   endif
 endif