openssl: add back the CAST cipher by default
authorFelix Fietkau <nbd@nbd.name>
Sun, 24 Jul 2016 12:41:50 +0000 (14:41 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 24 Jul 2016 12:42:18 +0000 (14:42 +0200)
At least netatalk and some ipsec packages use it

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/libs/openssl/Makefile

index 47594a55ba08ee6c17c2b6c699f553e0f970bcd6..9fbefa581a2b6ad1f6361db5cb5efc23954baa71 100644 (file)
@@ -97,7 +97,7 @@ endef
 
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5 \
 
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5 \
- no-whrlpool no-whirlpool no-seed no-cast no-cmac
+ no-whrlpool no-whirlpool no-seed no-cmac
 OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2 no-ssl2-method no-heartbeats
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
 OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2 no-ssl2-method no-heartbeats
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO